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About This Guide 

Pro/ENGINEER Wildfire Release Notes highlights the new 
functionality for this release. A streamlined user interface provides 
maximum visual feedback, more accuracy with less typing, and a new 
dashboard for smart input for features in Pro/ENGINEER. The new 
Navigator provides easy access to a collaborative environment with 
shared connectivity for users, Web access, and integrated data 
management. 

The release notes are organized according to the Pro/ENGINEER 
functional areas that appear on the Pro/ENGINEER Help Center home 
page. 

Resources and Services 
For resources and services to help you with PTC (Parametric 
Technology Corporation) software products, see the PTC Customer Service 
Guide. It includes instructions for using the World Wide Web or fax 
transmissions for customer support. 

Documentation for PTC Products 
PTC provides documentation in the following forms for Pro/ENGINEER 
Wildfire Preproduction: 

• Context-sensitive Help 

• PTC Customer Service Guide, Pro/ENGINEER Wildfire 
Preproduction Installation and Administration Guide in PDF 
format on the product CD-ROM. To view and print PDF books, you 
must have the Acrobat Reader installed. 
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• Pro/ENGINEER Help Center with a global search facility and 
Quick Links to helpful introductory information. 

When your PTC software has been installed, you can drag  from 
the Pro/ENGINEER menu bar to any dialog box to get Help or right-
click on any menu.  

PTC Documentation Conventions 
PTC documentation uses the following conventions. 

Convention Item Example 

Bold Menus paths, dialog box 
options, buttons, and 
other elements from the 
user interface 

Click File > Save. 
Assignee check box 
License File dialog box 

Courier User input, system 
messages, file names 

Processing 
completed. 

Courier with less-than 
and greater-than symbols   
(< >) 

Variables for which the 
user substitutes an 
appropriate value 

output=<LOADPOINT> 



 1-1 

1  
Fundamentals 

Pro/ENGINEER Fundamentals and Design Conferencing provide basic 
information about Pro/ENGINEER Wildfire Help. Highlights of new 
functionality for this release follow. 

Pro/ENGINEER Fundamentals 

PDM Information in the Model Tree 

Benefits 

Better visibility of the status of the models in session keeps you 
informed. 

A new Database Params option has been added to the list of types of 
information that can be displayed in the Model Tree. By selecting this 
option (Settings > Tree Columns from the Model Tree), you can show 
important PDM information for the models in session. This information 
includes PDM lifecycle data and the ¿editable status¿ of the object in 
session. 

Menu Location 

Settings > Tree Columns from the Model Tree 

Display of Clipped Views  

Benefits 

The display of the clipped view can be applied to both assemblies and 
parts and allows for a clearer display of the 3D models. 
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After you create a cross section, click the Display tab and change the 
Visibility Options. You can show either the front or the back of the 
model based on the cross section selected. A preview of the model with 
arrows to indicate directions shows which side is considered the front or 
back. You can also display the cross section in the clipped view. The 
clipped view remains visible even after you close the Model Sectioning 
tool.  

Menu Location 

Tools > Model Sectioning 

Support for HTTP and FTP File Locations  

Benefits 

The support for HTTP and FTP file locations provides users with 
improved file- and data-sharing capabilities. 

Built-in Web protocols extend the reach of Pro/ENGINEER from the 
desktop to the Internet. Internet locations (such as ftp://ftp.ptc.com) can 
now be registered with Pro/ENGINEER through the Server Registry 
command in the Tools menu. After a location is registered with 
Pro/ENGINEER, it is available to all Pro/ENGINEER file operations 
such as File > Open, File > Backup, Component > Assemble, and 
Component > Replace. You can also enter an HTTP or FTP address 
into the Open dialog box. Note that saving to simple HTTP locations is 
not supported, and simple HTTP locations are not, therefore, available 
through the Server Registry. 

Menu Location 

User Area connection on the Connections navigator 

Pro/ENGINEER Wildfire Home Page 

Benefits 

The Pro/ENGINEER home page can increase productivity by 
presenting useful information on startup. 

By default, Pro/ENGINEER displays the current Pro/ENGINEER home 
page on startup. You can customize this default behavior in two ways 
(1) Click Tools > Customize Screen > Browser. Click or clear the 
Expand Browser by default when loading Pro/E check box. The 
Pro/ENGINEER home page will still load, but it will not be displayed 
on startup; or (2) Set the web_browser_homepage.config 
configuration option to display a different home page. 
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Menu Location 

Pro/ENGINEER browser 

Console Records Server Transactions 

User Interface 

Benefits 
Transactions with a server can execute in the background, allowing you 
to continue working in Pro/ENGINEER. The console records all 
background messages and statuses. 

Many Windchill transactions run asynchronously in a Pro/ENGINEER 
background thread. This means that long-running Windchill 
transactions (such as uploading large assemblies) will not stop you from 
using Pro/ENGINEER while the transaction completes. At any time 
during or after the transaction, you can check the console for progress 
on uploading and downloading files.  

Menu Location 
Console icon on the Pro/ENGINEER status bar or from the 
Pro/ENGINEER menus (Tools > Console) 

Browser Integration with Help 

Benefits 

Pro/ENGINEER has better control of the Help browser, which provides 
improved usability of the Help system. 

Pro/ENGINEER Help is now displayed in a floating version of the built-
in Pro/ENGINEER browser. The Pro/ENGINEER browser provides all 
of the capabilities of the Help system, but improves overall usability 
when compared to previous Pro/ENGINEER releases, which used an 
independent browser. The Help browser remains on top of the 
Pro/ENGINEER window and remembers its last size and location. You 
can also create bookmarks from the Help browser. 

Menu Location 

Help menu 
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Enhanced Drag Capabilities 

Benefits 
The enhanced drag capabilities make many file operations simpler and 
faster to use. 

Pro/ENGINEER Wildfire provides enhanced file management through 
expanded drag capabilities. File data, such as Assemblies, Sub-
Assemblies, Parts, and user-defined features, can be dragged into a 
Pro/ENGINEER session for retrieval; Zipped files can be dragged into a 
Pro/ENGINEER session or input panels and are unzipped 
automatically; Files can be dragged onto the Model Tree to determine 
exactly where in the model the data will be added; Files can be dragged 
from the embedded browser into the Pro/ENGINEER graphics window 
or Model Tree; Files can be dragged into the Pro/ENGINEER browser 
and processed by the browser according to the browser MIME type 
settings. 

Menu Location 
N/A 

Improve and Enhance Dynamic View Manipulation Capabilities 

Benefits 
While using mouse interactions and modifier keys, you can focus on 
tasks to be completed. Expanding upon modern standards, 
Pro/ENGINEER Wildfire provides viewing-related capabilities via the 
middle mouse button. 

Pro/ENGINEER Wildfire provides two direct methods of viewing 
objects using the mouse basic viewing capabilities and advanced 
options. Basic viewing capabilities include (1) Spin - Middle-click and 
drag the object. (For 2D objects use Pan instead.); (2) Zoom - Hold down 
CTRL, middle-click, and drag the object. (Roll wheels can perform zoom 
also.); (3) Pan - Hold down SHIFT, middle-click, and drag the object. 

Advanced viewing options, such as spinning around a specific vertex, 
are also available. You can turn off the spin center and use the pointer 
to define the point at which the model will spin. You can select an 
entity to spin about a specific edge or vertex. 

Menu Location 
N/A 
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Using Keyboard Modifiers and Mouse Buttons 

Benefits 
You can use standard Microsoft keyboard functions and mouse 
operations in Pro/ENGINEER. For example, right-click to access 
shortcut menus. 

Pro/ENGINEER mouse operations and keyboard modifiers (CTRL and 
SHIFT) provide many productivity-enhancing shortcuts using the 
familiar Microsoft standards. For example, use CTRL to select multiple 
objects, or use SHIFT to select all the features between two selections 
from the Model Tree. 

Menu Location 
N/A 

Windchill PartsLink Integration  

Benefits 
With access to PartsLink, you can easily locate and download 3D 
models directly from suppliers, avoiding the need to create them 
yourself. 

Selecting Catalogs on the Connections navigator displays a PTC Web 
site of catalogs that are powered by Windchill PartsLink. From this site 
you can browse the catalogs directly or choose to personalize the 
Connections navigator by adding links to the catalogs that you use 
most frequently. The online catalogs offer powerful search and browse 
capabilities, so you can quickly locate parts and download them directly 
into Pro/ENGINEER. 

Menu Location 

The Connections navigator 

Selecting with Pick Boxes 

Benefits 

Consistent selection tools throughout Pro/ENGINEER provide 
familiarity. You can select multiple items at any time. 

Selection has been redesigned to make it more user-friendly and 
consistent throughout Pro/ENGINEER. You have the same tools for 
selection and have the ability to select multiple objects at any time. 
Holding down the left mouse button and dragging the pointer creates a 
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pick box for selecting multiple items. Selection filters control the scope 
of items that can be selected. 

Menu Location 

Hold down the left mouse button and drag.  

Undo and Redo Support 

Benefits 

Use Undo and Redo to reverse or redo an action, thereby avoiding the 
need to recreate an attribute after mistakenly deleting it. 

Standard Undo/Redo support is available for feature options and 
settings. Your actions are recorded in a stack that you move through 
with top-level icons or with standard keyboard shortcuts (CTRL + Z). 

Menu Location 

Edit > Undo or Edit > Redo 

System Parameters from Mass Properties 

Benefits 
You can calculate system mass property parameters on each 
regeneration, assuring up-to-date mass properties calculations. 

System parameters are created for mass properties and can be 
calculated on each regeneration or only when the mass properties are 
calculated. The new system mass property values can also be assigned 
through relations that are evaluated after the regeneration of the 
model Reporting of mass property values is expanded to provide more 
detailed component information in assemblies. 

Menu Location 

Edit > Setup > Mass Props 

Connections Navigator 

Benefits 

The Connections navigator provides convenient access to frequently 
used PTC Web resources and built-in Web applications. 

The Connections navigator contains built-in connections to Projects 
(powered by Windchill ProjectLink); Catalogs (powered by Windchill 
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PartsLink); PTC User Area and User Group (PTC User Group Web 
site); ptc.com; and Technical Support.  

Selecting any of these top-level connections takes you to the 
appropriate Web site, from which you can add connections to the 
Connections navigator. Each top-level connection on the Connections 
navigator holds a subscription to its target page. As long as the 
subscription is in effect, a change to bold type on a connection label 
indicates that the target page has been updated since you last visited 
that page. Subscriptions can be canceled or re-enabled by using the 
shortcut menu on the connection label. 

Menu Location 
The Pro/ENGINEER navigator 

Screen Customization of the Pro/ENGINEER Navigator and Browser 

Benefits 
You can increase your productivity by customizing the Pro/ENGINEER 
navigator and browser. 

The Customize Screen dialog box includes options to control the 
appearance and behavior of the Pro/ENGINEER browser and 
navigator. The new options are available from the Toolbars tab, the 
Navigation tab, and the Browser tab in the Customize dialog box. 

Menu Location 

Tools > Customize Screen 

Access to PTC User Area 

Benefits 

The User Area increases productivity and Pro/ENGINEER product 
awareness by providing access to the latest Pro/ENGINEER 
information, as shared by Pro/ENGINEER users worldwide. 

The PTC User Area is a Web-based resource hosted by PTC. It is 
designed to make product development professionals more productive 
by providing access to relevant tools and technical product information. 
Access to the The PTC User Area is a Web-based resource hosted by 
PTC. It is designed to make product development professionals more 
productive by providing access to relevant tools and technical product 
information. Access to the PTC User Area is built into Pro/ENGINEER 
through the Connections navigator. While you are connected to the 
Internet, click the User Area in the Connections navigator to display 
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the top page of the User Area in the Pro/ENGINEER browser. You can 
personalize the User Area by creating bookmarks to the pages that you 
visit most frequently. The bookmarks are added under the User Area in 
the Connections navigator. 

Menu Location 

User Area connection on the Connections navigator 

Built-In Web Browser 

Benefits 

The built-in Pro/ENGINEER browser provides Internet access while 
allowing you to remain focused on the model. 

The Pro/ENGINEER browser slides out from the Pro/ENGINEER 
Navigator. A "quick sash" provides one-touch retraction or expansion of 
the browser. The browser uses industry-standard browser components 
(Internet Explorer on Windows and Mozilla on UNIX) to deliver Web 
access in a user environment that works well with Pro/ENGINEER 
modeling tasks. Pro/ENGINEER uses the browser to display 
information from the Pro/ENGINEER model, such as from Feature ¿ 
Info, as well as information from Web services, such as Customer 
Support, online catalogs, Windchill Solutions, or the PTC User Area. A 
Web service accessed from the Connections Navigator executes in its 
own browsing thread, which Pro/ENGINEER creates as needed. You 
can switch between browsing threads using the tabs that appear above 
the browser toolbar. Only the general browsing thread (the first one 
created) has an address bar. 

Menu Location 
N/A 

Pro/ENGINEER Navigator                                          

Benefits 
The Pro/ENGINEER navigator provides access to data from a variety of 
sources in a familiar and easy-to-use interface. 

The Pro/ENGINEER navigator contains the following navigation tools: 
Model Tree - Provides navigation of and interaction with the current 
Pro/ENGINEER model; Folders - (Default) Provides navigation of the 
local file system, the local network, and Internet data; Favorites - 
Contains user-selected Web locations (bookmarks) and paths to 
Pro/ENGINEER objects, database locations, or other points of interest; 
Search - Provides search capability for objects in the data management 
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system. Note that the Search option appears when you declare a 
Windchill system as your primary data management system; History - 
Provides a record of Pro/ENGINEER objects you have opened and Web 
locations you have visited. Click the History icon on the browser toolbar 
to add the option to the Pro/ENGINEER navigator; Connections - 
Provides access to connections and built-in PTC solutions, such as 
Pro/COLLABORATE, PartsLink, and the PTC User area. 

Menu Location 
The left side of the user interface. 

Relations Tool                                      

Benefits 
The Relations tool allows you to quickly build relations in 
Pro/ENGINEER. 

The Relations tool allows you to switch between the levels of relation 
from a list. When working with multiple options, you can select a 
specific part, for example, from the graphics area. You can add 
relations that are calculated after the model geometry is regenerated 
using the Post Regeneration option in the Relations tool. You can use 
the familiar icons for cut, copy, paste, and delete to edit the relations. 
Another set of intuitive icons allows you to switch between dimensional 
values and symbols as well as insert relations-building information. 
Functions can be inserted from a list. Dimensions can be inserted by 
selecting them in the graphics area. Parameters can also be inserted 
from a list. You can manipulate relations. Dimensions in the graphics 
area can be highlighted as they are covered in the text window. 
Relations can be verified and sorted. 

Menu Location 

Tools > Relations 

Send To Capability in Pro/ENGINEER 

Benefits 

The Send To capability providers an easy way to exchange data with 
remote users through e-mail. 

The Send To capability allows you to send models from your current 
session by e-mail. You can choose an export format for the files, such as 
IGES or STEP, and compress the files into a Zip file before sending 
them. 
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Menu Location 

Click File > Send To or right-click Send To from the shortcut menu 
on the Model Tree. 

HTML Display of Text-based Information Files 

Benefits 
These text-based information files are reformatted and contain 
hyperlinks that allow interaction between the reports and the 
Pro/ENGINEER model. 

The following reports, which are accessible through the Info menu, 
have been reformatted and are now output in the Pro/ENGINEER 
browser: Feature, Model, Relations and Parameters, Feature List, and 
Audit Trail. The new format is more readable and provides additional 
functionality that allows you to interact with the model in session. For 
example, from the Information report you can highlight dimensions or 
navigate up and down parent-child hierarchies by clicking hyperlinks. 
For backward compatibility, the original text-based format is still 
available and can be reactivated by setting the info_output_format 
config.pro option to text (The default value is html). 

Menu Location 

Info menu 

Enhanced Surface Collection User Interface 

Benefits 

You can quickly transition from a single surface to a set of surfaces 
without having to navigate through menus or cancel actions.  

To begin, select a solid or quilt surface and press SHIFT to indicate 
that you want to use the selected surface as the anchor of a parametric 
surface set. While pressing SHIFT, you can only select surface sets that 
can be created from the anchor. The type of surface you construct 
depends on the type of anchor specified and the current target (the item 
over which the pointer is positioned). You can choose to construct loop 
faces, seed and boundary faces, or all solid faces surface sets. While you 
gather sets of surfaces, you are provided with valuable feedback. 

Menu Location 
N/A 
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Hyperlinks on Pro/ENGINEER Text 

Benefits 
Models can reference data that is outside of Pro/ENGINEER through 
hyperlinks. Models are more self-describing, which allows you to add 
extensive and reusable annotations. 

You can apply hyperlinks to 3D notes (as in previous releases) and 2D 
notes (including table notes). When a text item has an associated 
hyperlink, visual feedback is now given in the form of underlined text. 
In addition, when the pointer hovers over the note, a ToolTip displays 
the value of the hyperlink. Clicking the text while pressing CTRL 
activates the hyperlink. A context-sensitive pointer appears when you 
press CTRL while the pointer is on a note with a hyperlink. 

Menu Location 

Setup Note > Insert Hyperlink 

Advanced Selection and Definition 
Benefits 

You can now focus on desired results rather than on how to accomplish 
the task. By receiving continuous feedback on pending results you can 
achieve what you want on the first attempt. 

You can create extensive, easily expandable rule-based selections in all 
applications with a high degree of customizability using the Search 
Tool. The new dialog box provides easy access to items previously in the 
Select By Menu dialog box. In addition, you can collect and filter 
items for selection, search for items based on rules, and store your 
search results into layers.  

Menu Location 

Edit > Find 

Snapping Drag Handles 

Benefits 

You can quickly add definition to features by using consistent handle 
functionality while staying focused on the model or interacting with the 
dashboard. 

You can drag a handle to a specific value. You can also control handle 
values using other methods. You can move a handle to a specific 
reference by pressing SHIFT and moving the pointer to the desired 
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reference. To unsnap a handle from a reference, press SHIFT and drag 
the handle out of the snapping zone. The handle is no longer snapped to 
reference, and the dashboard displays the updated dimensions.  

You can also specify the dimension interval when dragging handles 
using the configuration option zzz_grid_interval, where zzz 
represents the different units that can be set on the model, such as 
inch_grid_interval when using inches. This option can be set to a 
value, such as .100, which will force all dragging to snap to 
dimensional values divisible by .100.  

You can also place the handle at an exact location by double-clicking 
the displayed dimension in the graphics area and entering the value. 

Menu Location 

N/A 

Enhancements to the Model Tree                                       

Benefits 

You can quickly perform feature operations by selecting features on the 
Model Tree rather than navigating through menus or dialog boxes. 

You can rename features easily by double-clicking the name in the 
Model Tree or by pressing F2. 

Menu Location 

N/A 

Working with Zip Files                                       

Benefits 

Sending and retrieving Zip files is an easy way to informally share 
Pro/ENGINEER data. 

Zip files that contain Pro/ENGINEER data can be opened in 
Pro/ENGINEER in one of the following ways(1) Click File > Open in 
Pro/ENGINEER and open the Zip file; (2) Drag the Zip file onto the 
Pro/ENGINEER graphics window. The Open dialog box opens; or (3) 
Drag the Zip file onto the Pro/ENGINEER browser. This action uses 
the browser's MIME setting and opens the Zip file using the currently 
configured application. 
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Menu Location 

File > Open and drag the Zip file onto the graphics window or the 
browser 

Designation Features and Geometry as Objects 

Benefits 
The ability to have features or geometry represent components enables 
faster assembly creation. Features and geometry can be designated as 
components and will be visible in Bills of Material and Pro/REPORT 
tables.  

You can designate features or geometry as objects in the Designate 
dialog box For example, a cosmetic feature can be designated as label 
and assigned a part number and cost. In the Bill of Materials, the 
feature would appear as a label part. In Pro/REPORT, the label part 
could also show values for cost and part number. Designating a 
Shrinkwrap feature will show that the shrinkwrap feature represents 
all of its reference models 

Menu Location 

Edit > Setup >Designate 

Design Conferencing 

Design Conferencing for Pro/ENGINEER Users 

Benefits 
Design Conferencing allows people to work together, reducing the need 
to travel to meet with one another. It also eases the flow of information 
between people. 

In Design Conferencing, one user creates a conference and invites 
others to join. These other users must be connected to the Internet. The 
leader has control of everyone's Pro/ENGINEER session.  

Users can also work offline. When they reconnect, the shared spaces 
are automatically synchronized. A shared space is an XML database 
and binary file stored on your machine, which is synchronized with all 
other machines participating in the same conference. The initiator can 
store models in the shared space. Everyone who accepts the invitation 
to the space can retrieve the model and make changes to it. When the 
model is saved back to the shared space, it is also copied to everyone 
else¿s shared space. Therefore, all participants always have the latest 
copy of a design.  
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Machines can be configured to automatically log into the Groove relay 
server, which is hosted by Groove Networks. Users can then see and 
search for each other online. 

Menu Location 

Tools > Conference 

ProjectLink Integration 

Benefits 
ProjectLink provides an excellent way for you to manage the exchange 
of project-related information with others. 

Windchill ProjectLink allows you to create a project on the ProjectLink 
server, upload data to the project directly from Pro/ENGINEER, and 
then invite other people to join the project. Only the people that you 
invite to your project can see and access your project data. Of course, 
ProjectLink provides much more than this, and the best way to explore 
the ProjectLink potential is to try it. To access the ProjectLink 
evaluation server, click Projects on the Connections navigator and 
follow the instructions on that Web page. The ProjectLink server 
contains a brief tutorial to get you started. After you have successfully 
created a project and registered it with Pro/ENGINEER, sending data 
to ProjectLink is as simple as saving it to another disk (clicking File > 
Backup). Retrieving data from ProjectLink is as easy as clicking File > 
Open. 

Menu Location 

Navigator > Connections tab > Projects  

Favorites Navigator 

Benefits 

The Favorites navigator increases productivity by allowing you to 
quickly return to frequently used sites. 

You can add the currently displayed Web page to your list of favorites 
either by using the shortcut menu or by using the Add to Favorites 
command on the Favorites navigator. The list of favorites is specific to 
the Favorites navigator and is different from the list of favorites that 
you may have created with your general browser. 

Menu Location 

Pro/ENGINEER navigator
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2  
Part Modeling 

Part and Sketcher make up the part modeling functional area for 
Pro/ENGINEER Wildfire Help. Highlights of new functionality for this 
release follow. 

Part 

Using the Extrude Feature 

Benefits 
One tool for extrude combines capabilities previously offered 
separately. This tool provides instant graphical preview with drag 
handles, during creation and redefinition 

After defining a sketch, you immediately get dynamic preview geometry 
based on intelligent defaults. Drag handles allow you to freely modify 
the depth to a desired value or snap the handle to a reference. With 
dashboard settings or shortcut menus, you can quickly change between 
options such as solid or surface, protrusion or cut, and solid or thin. 

Menu Location 

Insert > Extrude 

Working with Revolve Features 

Benefits 
The Revolve tool consolidates the capabilities of several features. It also 
provides instant graphical preview with drag handles during creation 
and redefinition. 
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After defining a sketch, you immediately see dynamic preview 
geometry based on intelligent defaults. Drag handles allow you to freely 
modify the angle of revolution to a desired value or snap the handle to a 
reference. With dashboard settings or shortcut menus, you can quickly 
switch between options such as solid or surface, protrusion or cut, and 
solid or thin. 

Menu Location 
Insert > Revolve 

Using the Trim Tool 

Benefits 
The new Trim tool gives you the ability to cut back quilts or surfaces 
using other quilts, surfaces or planes. You can perform the operation 
using graphical direct manipulation or dashboard-style controls. 

After you select the objects to trim, you immediately preview the 
resulting geometry. By specifying other options in the dashboard or in 
context-sensitive menus, you can progress to more complex trim 
geometry. For example, you can set attributes to keep the trimming 
surface or create a thin trim operation. 

Menu Location 
Edit > Trim 

Working with Rounds 

Benefits 

There is no distinction in the interface between simple and advanced 
rounds. All rounds are created with drag handles and interactive 
dynamic preview.  

Every round feature contains a least one set. By editing the set, or 
creating additional sets, you can make the round geometry more 
complex. For variable rounds, simply select a drag handle and right-
click to add a radius. Drag the base of the handle along the edge chain 
to control the position of the handle. Use a Shortcut menu to create full 
rounds and transitions. 

Menu Location 

Insert > Round 
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Pattern User Interface and Workflow 

Benefits 
The dashboard of the Pattern interface provides easy access to all the 
information necessary when creating or redefining patterns of parts or 
features. 

On the dashboard you can enter all the pertinent information when 
creating patterns of parts or features. You can enter the pattern type, 
number of instances and spacing directly on the dashboard. With the 
dashboard you can both create and redefine patterns. All the previous 
functionality for patterns is available on the pattern dashboard. 

Menu Location 

Edit > Pattern 

Working with the Move Tool 

Benefits 

The Move tool allows you to translate or rotate quilts, datum curves, 
and axes using graphical, direct manipulation, or dashboard-style 
controls. 

Select quilts, curves, or axes, and then activate the Move tool. Use the 
Move tool to translate or rotate by interacting with the dashboard or by 
using right mouse button actions. After you select a direction reference, 
an interactive geometric preview appears in which you can move the 
item to the desired location. 

Menu Location 

Edit > Move 

Separating Sketcher  

Benefits 

You can quickly redefine a feature’s shape by changing only the sketch 
feature. 

Sketch features now appear in a model’s Feature tree. In 
Pro/ENGINEER Wildfire, sketches can be redefined by simply 
expanding the feature group to change the sketch itself. Sketches can 
also be created prior to feature creation. This allows you to replace 
sketches easily by redefining the feature and selecting a new sketch as 
a reference. (In the past, sketches were absorbed by the feature and 
could only be changed by redefining the feature.) You can also continue 
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to create sketches within a feature tool by selecting the Sketch icon in 
the dashboard. After a sketch is used and the feature is completed, the 
sketch will automatically be hidden to clean up the display of the 
graphics area. NoteIf external sketches are referenced in a feature tool, 
the feature tool will create an independent copy of the original sketch. 

Menu Location 

Insert > Model Datum > Sketched Curve 

Working with Datum Coordinate Systems 

Benefits 
All the ways to create datum coordinate systems are consolidated and 
controlled by your selections on the model and from the options 
available in the streamlined dialog box. 

The Datum Coordinate System feature has dynamic preview and drag 
handles so that you can quickly create datum coordinate systems. All 
create options in the dialog box are also available when redefining the 
datum coordinate system. 

Menu Location 

Insert > Model Datum > Coordinate System 

Working with Datum Planes 

Benefits 

Using the datum planes interface, you can create, name, and size 
datum planes. You can construct planes using graphical direct 
manipulation or the dialog box. 

The Datum Plane feature has dynamic preview and drag handles so 
you can quickly create datum planes. All Datum Plane creation 
methods are consolidated and controlled by your selections and by the 
options available in the new streamlined dialog box. 

Menu Location 

Insert > Model Datum > Plane 
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Using the Draft Tool 

Benefits 
The Draft tool provides instant graphical preview with drag handles 
during creation and redefinition, which allows you to focus on the 
model or interact with the dashboard. 

The Draft tool consolidates all surface and solid draft features. By 
using drag handles or interacting with the dashboard, you can create 
simple or complex geometry. You can access advanced attributes 
through slide-up panels on the dashboard or by using the shortcut 
menu. As any attribute is defined or modified, the dynamic geometry 
preview updates, showing how those changes alter the model. 

Menu Location 

Insert > Draft 

Working with Extend 

Benefits 

The Extend tool provides instant graphical preview with drag handles 
during creation and redefinition so you can focus on the model or 
interact with the dashboard. 

The Extend tool allows for the use of drag handles and the dashboard to 
define extensions on surfaces. Adding a drag handle can create variable 
extensions. All extend types are available through interaction with the 
dashboard. As any of the extend definitions are modified, the geometry 
preview updates immediately.  

Menu Location 

Edit > Extend 

Feature Toolbar  

Benefits 

Intuitive icons provide quick access to the most commonly used 
features in Pro/ENGINEER. 

The Feature toolbar organizes the most common feature creation and 
edit tools into three toolbars. Creation tools such as extrude, revolve, 
sweep, style, and boundary blend are located in one toolbar. Standard 
engineering features such as holes, shell, draft, rounds and chamfers 
are located in a second toolbar. The third toolbar holds edit features 
such as move, mirror, pattern, and merge. 
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Menu Location 

N/A 

Creating Field Datum Points 

Benefits 

You can create field datum points and redefine the attributes for field 
datum points using one dialog box. 

The Field Datum Point dialog box allows you to quickly define 
placement planes. You can also set properties such as feature names 
using the Properties panel in the dialog box. 

Menu Location 

Insert > Model Datum > Point > Field 

Working with Fill 

Benefits 
The Fill user interface provides dynamic preview and a streamlined 
dashboard that is consistent for all features. 

The Fill tool allows you to quickly create a flat surface after selecting or 
sketching a closed section. 

Menu Location 

Edit > Fill 

Folder Navigator 

Benefits 
The Folder navigator provides quick access to Pro/ENGINEER data 
from a wide range of local or network-based locations. 

The Folder navigator provides a uniform and familiar way to access any 
data location that has been registered with Pro/ENGINEER. Some 
locations, such as the local file system, the current Pro/ENGINEER 
session, and the Network Neighborhood, are built in. Other locations, 
such as Windchill servers, a Pro/INTRALINK server, FTP locations, or 
Conference Spaces, can be added to the Folder navigator by registering 
these locations through Tools > Server Registry. Using the Folder 
navigator, you can browse registered locations. After finding a 
Pro/ENGINEER file or assembly of interest, the file or assembly can be 
loaded into Pro/ENGINEER. 
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Menu Location 

Pro/ENGINEER navigator 

History Navigator 

Benefits 

The History navigator increases productivity by allowing you to quickly 
return to a previously visited site. 

The History navigator, which appears in the Pro/ENGINEER navigator 
only when you click the History icon, manages the list of Web sites that 
you have visited through the Pro/ENGINEER browser. The History 
navigator shows the browser history as a list, which you can sort and 
manage. The History navigator is specific to Pro/ENGINEER and 
differs from the history list that is created and maintained by your 
general browser. 

Menu Location 

Pro/ENGINEER navigator 

Using the Intersect Tool 

Benefits 

You can use one tool to create curves at surface intersections or when 
projecting two separate curves. 

The Intersect tool consolidates two previous ways of creating curves. If 
you select two surfaces, the tool creates a curve at the intersection of 
those surfaces. If two sketched curves are selected, then a curve is 
created at the projection intersection of both sketches.  

Menu Location 

Edit > Intersect 

Working with Merge 

Benefits 

You can use direct modeling concepts and shortcut menus to toggle 
options such as Intersect or Join when creating merge features. 

The Merge tool provides a dashboard interface consistent with that of 
other features. The Merge tool collects two quilts and displays arrows 
indicating the sides of the quilt to keep. By default, the operation uses 
the Intersect function, but you can change this option to Join either by 
interacting with the dashboard or by using the shortcut menu. 
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Menu Location 

Edit > Merge 

Working with Patch 

Benefits 

The Patch tool provides instant graphical preview with drag handles 
during creation and redefinition so you can focus on the model or 
interact with the dashboard. 

The Patch tool consolidates features that add or remove material using 
quilts or surfaces and includes functionality for replacing solid surfaces 
with quilts. The Patch tool uses a dashboard and shortcut menus for 
advanced options. As any changes are made to the definition of the 
feature, graphical preview updates, showing how those changes affect 
the model.  

Menu Location 

Edit > Patch 

Using the Project Tool 

Benefits 
You can use direct modeling and advanced options on shortcut menus 
when projecting curves. 

The Project tool includes a dashboard and instant preview as you are 
working to project curves on surfaces or solids. Use the Dashboard or 
right-click to define or modify attributes. Geometry Preview updates 
immediately. 

Menu Location 

Edit > Project 

Working with Rib 

Benefits 

The Rib tool provides instant graphical preview with drag handles 
during creation and redefinition. 

The Rib tool allows you to interactively flip the material side and the 
width of the rib feature. All modifications can also be made in the 
dashboard. 
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Menu Location 

Insert > Rib 

Working with Sketched Datum Points 

Benefits 

You can create sketched datum points and redefine the attributes of all 
sketched points in the same dialog box.  

The Sketch Datum Point dialog box lets you quickly define sketching 
planes and references. You can also set properties such as feature 
names using the properties panel in the dialog box. 

Menu Location 

Insert > Model Datum > Point > Sketched 

Using the Sweep Tool 

Benefits 
One tool provides the capabilities of several features. The Sweep tool 
also provides instant graphical preview with drag handles during 
creation and redefinition. 

The Sweep tool consolidates the creation of sweep and variable section 
sweep features into one tool. After specifying a trajectory and defining a 
sketch, you get dynamic preview geometry of the sweep feature. Using 
CTRL, you can quickly add another trajectory and progress from a 
simple sweep to a variable section sweep. Dashboard settings, or 
shortcut menus, allow you to quickly change between options such as 
solid or surface, protrusion or cut, and solid or thin. Advanced 
attributes, such as defining a pivot direction, are available in slide-up 
panels on the dashboard. 

Menu Location 

Insert > Variable Section Sweep 

Using the Thicken Tool 

Benefits 
Use the new Thicken tool to produce solid geometry by providing a 
thickness for surfaces or quilts using graphical, direct manipulation, or 
dashboard-style controls 

The Thicken tool is an object-action tool. After you select a surface and 
enter the thicken tool environment, you are given preview geometry 
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with a drag handle. With a shortcut menu and the dashboard, you can 
add or remove material and exclude surfaces from thickening. 

Menu Location 

Edit > Thicken 

Using the Wrap Tool  

Benefits 

You can use direct modeling and advanced options on shortcut menus 
to wrap curves on surfaces or solids. 

The Wrap tool includes a dashboard and instant preview as you are 
working to create formed datum curves on surfaces or solids. You can 
also wrap a section with or without a sketcher coordinate system. 

Menu Location 

Edit > Wrap 

Creating Datum Points Offset from a Coordinate System 

Benefits 
You can both create and redefine points in the progressive user 
interface for datum points. You can use direct modeling concepts and 
shortcut menus to toggle placement options. 

The dialog box for creating datum points offset from a coordinate 
system allows you to enter explicit x-, y-, and z-values or drag points 
along the three axes. You can enter additional points or import a file 
containing the location of the points. Using a familiar tabular interface, 
you can easily edit point values and names in the dialog box. 

Menu Location 

Insert > Model Datum > Point > Offset Coordinate System 

Streamlined Datum Point Feature 

Benefits 
You can both create and redefine datum points. You can also use direct 
modeling concepts and shortcut menus to toggle placement options. 

The enhanced datum point feature consolidates all creation tools, such 
as On Surface, Offset Surface, Curve X Srf, On Vertex, Three Srf, At 
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Center, On Curve, and Offset Point, in one dialog box. The tool provides 
graphical preview of points based on the references selected. 

Menu Location 

Insert > Model Datum Point 

Working with Boundary Blend Surface 

Benefits 

The Boundary Blend tool provides instant graphical preview with drag 
handles during creation and redefinition so you can focus on the model 
or interact with the dashboard.. 

The new Boundary Blend tool provides all the functionality needed to 
create surfaces through a set of curves. The dashboard allows you to 
have full control over the order in which curves are passed through, 
tangency conditions, and control points for the surface. The dynamic 
geometry preview updates as the surface attributes are modified or 
defined in the dashboard. 

Menu Location 

Insert > Boundary Blend 

Working with Datum Axes 

Benefits 
Using the datum axes interface, you can create, name, and size datum 
axes. You can construct axes using graphical direct manipulation or 
using a new dialog box. 

The new Datum Axis feature has dynamic preview and drag handles so 
you can quickly create datum coordinate systems. All create options in 
the dialog box are also available when redefining the datum coordinate 
system. 

Menu Location 

Insert > Model Datum > Axis 

Working with Sketched Datum Curves 

Benefits 

You can both create and redefine sketched datum curves through the 
same dialog box. You can also modify the attributes of all sketches 
using this dialog box. 
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The new Sketch Datum Curve dialog box allows you to quickly define 
sketching planes and references. You can also set properties such as 
cross-hatching and section names using the Properties panel in the 
dialog box. 

Menu Location 

Insert > Model Datum > Sketched Curve 

Working with Offset 

Benefits 
You can use one tool to create surface and curves offsets while 
leveraging direct modeling concepts and shortcut menus to toggle 
advanced options such as excluding individual surface patches. 

The new offset tool combines eight features and incorporates Object-
Action capability to provide ease-of-use and intuitive feature creation. 
This tool can be used on both surfaces and curves. You can quickly 
create the desired feature by interacting with drag handles and 
dynamic preview or by interacting with the dashboard. The eight 
features that have been consolidated are Offset curve, From curve, 
Offset from surface (curve), From boundary, Surface offset, Tweak 
offset, Draft offset, and Area offset. 

Menu Location 

Edit > Offset 

New Dimension Type for Rounds 

Benefits 

You create conical rounds with drag handles and interactive dynamic 
preview, which allows you to quickly preview the geometry prior to 
completing the feature.  

To access the new dimension type, click the Sets slide-up panel and 
change the round type from Circular to D1 x D2 Conic. Drag handles 
to control both leg dimension values and the conic handle appear. If you 
change a value on the dashboard, the preview geometry updates 
immediately. 

Menu Location 

Insert > Round 
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Enhanced Fill Pattern Capability 

Benefits 
The new fill pattern functionality saves significant time when 
replicating many objects in a specific area and is more intuitive than 
previous techniques. 

Use fill patterns to populate a region by defining a sketch or to fill a 
region using various spacing types. You can also define the distance 
between instances and the distance between the instances and the 
sketched boundary. If a circular spacing type is defined, use fill 
patterns to define the rotation of the pattern and radius. To remove 
unwanted instances, select directly on the preview for each pattern. 

Menu Location 

Edit > Pattern 

Working with the Mirror Tool 

Benefits 

When you use the Mirror tool, you can use direct modeling concepts and 
shortcut menus to toggle advanced options, such as keeping the original 
feature. 

Using an object-action approach, you can select quilt, curves, or axes 
prior to opening the Mirror tool. Once in the tool, as soon as you select a 
plane, a graphical preview appears. You can interact with the 
dashboard or use shortcut menus for options, such as keeping the 
original quilt, curve, or axes. 

Menu Location 

Edit > Mirror 

Using the Shell Feature 

Benefits 

You can leverage direct modeling concepts to drag thickness handles 
and to use shortcut menus to toggle advanced options, such as defining 
special thickness surfaces. 

When using the Shell tool, you can use either an object-action or action-
object approach. With the drag handles you can pull dimensions or 
enter a value directly on the screen. Press and hold CTRL to select 
multiple surfaces to exclude. You can define advanced attributes, such 
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as special thickness surfaces, by using a shortcut menu or by 
interacting with the dashboard. 

Menu Location 

Insert > Shell 

Working with the Hole Feature 

Benefits 

A compact and functional user interface provides enhanced hole 
functionality. 

You can interact with preview geometry for hole placement, size, and 
depth. By snapping drag handles to appropriate references, you can 
quickly define hole features. You can also interact with the dashboard 
for other hole types, such as standard holes or sketched holes. 

Menu Location 

Insert > Hole 

Working with the Copy Feature 

Benefits 

With one tool you can create surface copies and composite curves. 

You can leverage direct modeling concepts and shortcut menus to toggle 
advanced options, such as creating an approximate or exact curve. The 
Copy feature consolidates the SURF COPY, SURF COPY BY TRIM, 
and Composite Curve features. You can work with your model using 
direct graphical manipulation and dashboard-style interaction. You 
receive immediate preview display feedback whenever possible and 
before you must commit to the feature. 

Menu Location 

Edit > Copy 

New User Interface for Chamfers 

Benefits 

You can quickly create chamfers by selecting edges and dragging a 
handle. Using chamfer sets and transitions, you can create complex 
chamfers using one chamfer feature. 
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The chamfer tool operates similarly to the round tool. Users can add 
edges to one chamfer set by pressing CTRL while selecting the edges. 
Users can create new sets by selecting alternate model edges. There 
also is a transition mode that allows users to define the geometry that 
intersects multiple chamfer sets. Users can interact with the dashboard 
to control the dimensioning scheme needed for the chamfer desired. 

Menu Location 

Insert > Chamfer > Edge Chamfer 

Sketcher 

Enhanced Spline Creation and Modification 

Benefits 
You can modify splines using the same tools as used for Style features. 

You can create and modify freeform splines in Sketcher using tools that 
are similar to other curve tools in Pro/ENGINEER, for example, those 
in Style and Restyle. 

Menu Location 

Sketcher > Modify 
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3  
Detailing 

Pro/DETAIL includes tools to prepare drawings of parts and 
assemblies. Highlights of new functionality for this release follow. 

Using 2D Drawing Symbols 

Benefits 
You can capture more information in the 3D model using drawing 
symbols. 

Drawing symbols can be displayed in 3D parts and assemblies. They 
are placed on annotation planes that rotate with the model. Annotation 
planes are similar to datum planes but are not visible to the user. This 
functionality supports the new ASME Y14.41 drawing standard 
currently under review but not yet released. 

Menu Location 

Setup > Symbol 

Support for Drawing Standards 

Benefits 
Enhanced support of the major drawing standards such as ASME, ISO, 
and JIS makes it easier to create the desired drawing. 

A number of improvements have been made to enhance support of the 
major drawing standards. Enhancements include (1) Datum axes can 
be attached to a cylindrical surface shown as a silhouette; (2) New 
options have been added for datum targets, including rectangular and 
circular target shapes; (3) For ISO, the leader line now attaches to the 
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center of the stack of geometric tolerances instead of the dimension for 
cases where gtols have been placed in a dimension; (4) For ISO, 
multiple leaders can be created for geometric tolerance control frames; 
and (5) Radius dimensions can be displayed according to the JIS 
standard. 

Menu Location 
N/A 

Enhancements to the Drawing User Interface  

Benefits 
The number of mouse clicks and mouse movements is reduced. You can 
initiate all commands from one toolbar. 

All commands can be accessed from the main toolbar or from shortcuts 
menus. 

Menu Location 

Reference Designators as 3D Notes 

Benefits 

Locating unique components is faster and easier because you can 
display component reference designators as 3D notes.  

Component reference designators are shown automatically as 3D notes 
in your ECAD assemblies. You can quickly and easily locate any 
component by name. To activate this functionality, click Tools > 
Environment and click the Reference Designators check box. 
Customize your toolbar to display the reference designators icon so you 
can quickly turn on or off reference designators. 

Menu Location 

Tools > Environment > Display Reference Designators 

Improved BOM Balloon Behavior 

Benefits 

You can save time with the improved initial placement of balloons. You 
can display desired balloons for multiple occurrences of the same 
component. 

Improvements to BOM balloons include (1 )Improved placement - BOM 
balloons are placed more intelligently around a view to avoid 
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overlapping; (2) Automated cleanup - New functionality allows balloons 
to be positioned relative to view borders; (3) Multiple BOM balloons for 
the same component - You can show additional balloons for the same 
component using the same index number; and (4) Highlight balloons 
from table - You can find corresponding balloons by selecting the row in 
the table. Select a balloon to highlight the table row. 

Menu Location 

Edit > Cleanup > BOM Balloons and Table > BOM Balloons > 
Add Ref Balloon 

Sending a Drawing by E-mail 

Benefits 

Pro/ENGINEER saves you time by creating a Zip file of the active 
drawing and its required model files. 

Pro/ENGINEER can package and send a drawing file and its required 
model files to another e-mail recipient. You have the option of creating 
a Zip file or sending the files as attachments. 

Menu Location 

File > Send To 

Notes on Bend Lines 

Benefits 
A 3D note is automatically created on any bend, resulting in increased 
productivity. The note increases your understanding of the part while 
looking at the Flat Pattern.  

The Note on each bend of the side and the angle of bending makes 
looking at a Flat Pattern much more intuitive. You can use the Note in 
Drawing mode to increase your understanding of the part, thus 
increasing your productivity.  

Menu Location 

N/A 
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Enable True Type Fonts for Non-European Languages 

Benefits 
The ability to modify text using True Type fonts provides flexibility 
when creating drawing documents and can improve the appearance of 
these documents. 

The ability to use industry standard True Type fonts with non-
European languages has been added to Pro/ENGINEER. You can 
modify the text font and use True Type fonts. 

Menu Location 

Double-click a note and click Font from the Text Style tab.  

Breaking Crosshatch Lines  

Benefits 

Breaking crosshatch lines around dimension text and notes improves 
the clarity of the drawing. 

The crosshatch lines of a section view can be broken around dimension 
text and notes to improve clarity. To enable this functionality, click the 
option Break Crosshatching under the Text Style tab of the 
Properties dialog box.  

Menu Location 

Double-click a dimension or note or click the Break Crosshatching 
option under the Text Style tab. 

Working with the Repeat Region Parameter 

Benefits 

The repeat region parameter reduces the number of required tables by 
listing multiple configurations of an assembly in one table using one 
parts list. The repeat region parameter lists multiple configurations of 
an assembly in one table using a single parts list. The parameter can 
specify any other assembly model, including family table instances or 
generic assemblies. A detail setup option, sort_method_in_region, 
provides flexibility for sorting regions alphabetically and numerically. 

Two new repeat region parameters have been added to locate assembly 
components on a drawing using the drawing grid. The parameter 
asm.mbr.pos_loc.all_views lists the locations of the component in all 
views on the drawing. The parameter asm_mbr. pos_loc.view name lists 
the locations of the component in a specified view. 
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Menu Location 

Table > Repeat Region > Column Model/Rep 

Enhancement to Parametric Drafting  

Benefits 

The improved snapping to axes makes it easier to create 2D circles and 
arcs. This is especially helpful when creating full and partial bolt-hole 
circles. Associative Use Edge and Offset Edge allows easier creation of 
intelligent 2D entities on drawing views. 

While creating a 2D arc or circle, the arc center or arc will snap to axes. 
The 2D commands Use Edge and Offset Edge can be made associative 
to the model. This means that the 2D entities created using these tools 
will update if the model is modified. 

Menu Location 

Sketch > Edge > Use and Sketch > Edge > Offset 

Modifying Angular Dimensions 

Benefits 

You can directly input angular dimensions in degree-minute-second 
format when modifying dimensions in a drawing. You can modify 
angular dimensions directly in degree-minute-second format instead of 
as decimal input. The Properties dialog box for dimensions displays 
dimension values as degree-minute-second. You can input new values 
in the chosen format. 

Menu Location 
Double-click an angular dimension. Select a format from the list under 
Angular Dimension Units. 

Creating Hyperlinks in Drawings 

Benefits 

The support of hyperlinks expands flexibility within the drawing 
environment and adds more information to the drawing. You can now 
create hyperlinks on drawing sheets. 

Menu Location 

Double-click a note. Select Hyperlink from the Text tab 
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4  
Assembly and Welding 

Assembly and welding applications for Pro/ENGINEER Wildfire Help 
include the following software: Pro/ASSEMBLY, Advanced Assembly 
Extension (AAX), Assembly Performance Extension, Pro/PROCESS for 
Assembly, and Pro/Welding. Highlights of new functionality for this 
release follow. 

Pro/ASSEMBLY 

Enhanced Reference Control 

Benefits 

More restrictive exceptions to global reference rules can now be 
enforced, which allows wider use of the top-down design methodology. 

Reference control options are accessible for a single, specific component. 
If a global reference rule and a component-specific reference-control 
rule conflict, the more restrictive rule is used. For example, if a specific 
component has reference control to none and the global reference 
control is set to any, then any component can be referenced except the 
component with the reference control. On the other hand, if the global 
reference control is set to none and a specific component has reference 
control set to any, then no component can be referenced. 

Menu Location 

Edit > Model > Reference Control (for component reference control) 

Edit > Assembly Settings > Reference Control (for global reference 
control) 
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Component Replacement  

Benefits 
The simplicity of this new method of replacement benefits both new and 
existing users. New users can easily explore the capabilities, and 
existing users can work faster. 

The method for replacement falls into two categories: By Model and By 
Copy. To replace a component By Model, Pro/ENGINEER offers 
options such as Family Table, Interchange, Reference Model, 
Layout, and Manual Replacement. Pro/ENGINEER recognizes the 
appropriate options. For example, the Family Table option is 
unavailable unless the component has family table instances. If you 
select By Copy, a copy of the component replaces the original. The 
new, copied component is automatically assembled in place. 

Menu Location 

Edit > Replace 

Shrinkwrap Components in Bills of Material  

Benefits 
Using a shrinkwrap to represent a set of components can dramatically 
reduce the system requirements for high-quality visualization and 
regeneration of the model. Shrinkwrap features can now be represented 
in Bills of Material with their reference components. 

Any shrinkwrap feature that is designated as an object will be 
identified with its parent components. Click Edit > Setup > 
Designate to open the Designate dialog box. Choose the Objects tab, 
and select any shrinkwrap feature. Any referenced objects of the 
shrinkwrap feature appear in the designation list. Create the Bill of 
Materials using Info > Bill of Materials, and check the Designated 
Objects box. The Bill of Materials will list the components represented 
by the shrinkwrap feature in any assembly that contains that feature. 

Menu Location 

N/A 

Angle-Offset Constraint for Component Assembly 

Benefits 
You can now create an angle offset constraint between two planar 
surfaces to specify the rotation of a cylindrical component.  



Assembly and Welding 4-3 

After you create an axis alignment or an insert constraint, the angle-
offset constraint is available in the Component Placement dialog 
box. 

Menu Location 
Insert > Component > Assemble 

Automatic Component Placement  

Benefits 

After you define assembly constraints and references within a 
component interface, you can simply drag the component into an 
assembly. 

Similar references are identified as they are brought into an assembly. 
As a result, assembly constraints are automatically satisfied. The 
system locates matching references in the assembly for the constraints 
and references defined in the component.. Multiple interfaces can be 
created for an individual component. Within each interface, multiple 
constraints, such as mate and align, are defined along with a 
corresponding component reference. After these interfaces are defined, 
they can be used for assembly. Any one interface set, which represents 
multiple constraints, can be selected for assembly. Automatic 
placement also allows multiple occurrences of one component to be 
placed simultaneously. 

Menu Location 

Edit > Setup > Component Interfaces 

Tools > Assembly Settings > Component Placement 

User-Defined Feature Enhancement - Subassembly Inclusion 

Benefits 

UDFs can now be used on a larger scale for automation and standards 
promotion. 

When creating a UDF, you can select subassembly components created 
in the assembly along with the created part components and features. 

Menu Location 

Tools > UDF Library 
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Working with Flexible Models 

Benefits 
Flexible components allow the same component to be shown in different 
geometric representations and still report one item on the Bill of 
Materials. 

You can make a component flexible after you place it by selecting a 
component or subassembly and clicking Edit > Make Flexible. You 
can define the variation in geometric states manually, or it can be 
derived as a dimensional value from an analysis result, such as 
distance. After the value is determined, there are four options to define 
the flexibility. 

You can also predefine flexibility in a component by clicking  
Edit > Setup > Flexibility. You can use this flexibility definition 
each time the component is added to an assembly.  

Menu Location 

Edit > Make Flexible 

Bulk Item Templates and Measure Parameters  

Benefits 

Bulk items have been enhanced for all associative measurement 
parameters and encourage the reuse of data by providing Bulk 
Template parts.  

You can create Bulk Template parts by clicking File >New >Bulk to 
open the Bulk Item Definition dialog box. From this dialog box, you 
can create bulk item parameters, relations, and family tables of the 
bulk part. Bulk parameters have been enhanced to include measure 
parameters. For example, you can create an Area Measure type 
parameter called PAINT. When this bulk item is added to an assembly, 
you will be prompted to select a surface as a reference for the PAINT 
parameter. The surface area will be calculated and used as the value of 
PAINT. Other new parameter types are Length Measure, Distance 
Measure, Diameter Measure, Angle Measure, and Parameter Sum. The 
Parameter Sum type will add the values of all parameters of the same 
name. 

Menu Location 

File > New > Bulk 
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Advanced Assembly Extension (AAX) 

Working with Inheritance Features 

Benefits 

The expansion of the inheritance feature furthers the ability to create 
inheritance features and to manipulate derivative models for 
manufacturing purposes.  

During the creation of an inheritance feature, you can choose options to 
inherit individual parameters and geometric tolerances. You can also 
define new values for all inherited items. The derived object (target 
part of the inheritance feature) can be retrieved and modified without 
retrieving the original model. Inheritance features can be created 
within an assembly in the same manner that copy geometry features 
can be created. Inheritance features can be used to remove material 
from a part. While replacing a component, you can replace a reference 
model with its derived object or vice versa. This capability uses the 
reference-forwarding capabilities to automate the replacement. You can 
create inheritance features in sheet metal components. 

Menu Location 

Insert > Data Sharing > Inheritance Feature 

Assembly Performance Extension 

Symbolic Simplified Representation 
Benefits 

Symbolic simplified representation, or lightweight simplified 
representation, dramatically reduces the system requirements for high-
quality visualization and quick regeneration times. 

By default, symbolic simplified representations replace components 
with a datum point. This representation can be customized to any 3D 
symbol, including the orientation of the annotation plane. 

Menu Location 

View > Representation > Symbolic Only 
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External Simplified Representation  

Benefits 
External representation dramatically reduces the system requirements 
for high-quality visualization and quick regeneration times by more 
widely proliferating its use. External simplified representations are 
created without modifying the master assembly. 

The Create Assembly dialog box provides all of the new and existing 
simplified representation options. The creation process generates a new 
assembly file with a dependency on the original assembly. You can also 
create External simplified representations by copying an internal 
simplified representation in the View Manager dialog box. 

Menu Location 

File > New > Assembly > External Simplified Representation 

View Manager 

Benefits 

The View Manager provides the capability for managing and using 
various states.  

The basic workflow for creating, editing, and switching between 
simplified representations, exploded states, display states, and 
orientation states has changed. In Pro/ENGINEER Wildfire, the model 
is constantly in a working state. Components can be switched to hidden 
line or excluded, or a component can be moved to represent an exploded 
state without using any dialog boxes. Changes are then stored using 
the View Manager. 

Menu Location 

View > View Manager 

Pro/Welding 

Creating Lightweight Edge Preparation Features in Welding 

Benefits 

You can quickly create edge preparation features with minimal impact 
on assembly performance. 
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For welds requiring edge preparation, you can create a lightweight edge 
preparation that captures the information about the edge preparation 
but displays it in the model similar to a datum curve. 

Menu Location 

From the Weld Creation dialog box, click Environment and specify 
Light for Edge prep geom type. 

Creating Automatic Weld Notches 

Benefits 

You can save time by automatically creating weld notches to provide 
clearances for welds. 

You can create weld notches automatically when defining a weld. Weld 
notch features are cuts that create clearance in intersecting geometry 
for the weld feature. 

Menu Location 

From the Weld Creation dialog box, click Notch. 

Working with Edge-Surface Fillet Welds 

Benefits 

Welding supports use cases where edge-to-surface welds are required. 

Welding now supports additional use cases where edge-to-surface 
welds are required. A new weld type has been added in addition to the 
existing fillet types edge-edge and surf-surf. 

Menu Location 

From the Weld Creation dialog box, select the fillet weld type and 
Edge > Surf from the REF OPTIONS menu 
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5  
Pro/ENGINEER Interface 

Pro/ENGINEER Interface for Pro/ENGINEER Wildfire provides direct 
data exchange and industry standard translators. Highlights of new 
functionality for this release follow. 

ProductView Express 2.0 

Benefits 

ProductView Express is a Web browser plug-in that lets you view 
Pro/ENGINEER models outside of Pro/ENGINEER. 

This version of ProductView Express is shipped with Pro/ENGINEER 
Wildfire and is installed automatically. It is used for previewing 
Pro/ENGINEER models from the Pro/ENGINEER embedded browser 
or from outside of Pro/ENGINEER.Performance is improved and spin, 
pan, and zoom controls are now similar to those in Pro/ENGINEER. 
You can now use ProductView Express to view Pro/ENGINEER section 
(.sec) and manufacturing (.mfg) files.ProductView Express is also 
available as a free download from www.ptc.com. 

Menu Location 

N/A 
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6  
Electrical Design 

Electrical design in Pro/ENGINEER Wildfire Help includes the 
following applications: Pro/DIAGRAM, Pro/CABLING, Pro/HARNESS, 
and Pro/ECAD. Highlights of new functionality for this release follow. 

Harness Family Tables 

Benefits 
The creation of family tables of harness parts accommodates multiple 
configurations of harnesses or similar harnesses of different lengths. 

Harness wiring is an addition to the Pro/ENGINEER family table 
functionality. With Pro/ENGINEER Wildfire, you can create family 
tables of assemblies and vary the configuration of the harness parts in 
them. 

Menu Location 
Family tab 

User-Defined Terminator Parameters 

Benefits 
You can report terminator parameters like manufacturer, material, and 
internal part numbers, making your BOMs more complete and 
accurate. 

Terminator files are similar to spool information files. When the 
terminator table functionality is used, the terminator is applied to the 
wire ends as specified. The terminator then has all of the parameters 
stored in the new terminator files. This terminator information can be 
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reported in wire lists, BOMs, and connector loading tables, as 
necessary. 

Menu Location 

Terminators 

Improved Bundle Alignment 

Benefits 
A 3D harness looks more realistic. Assembly drawings for downstream 
documentation applications can be created more easily with less 
modification. 

When you create a harness in Pro/ENGINEER Wildfire, the enhanced 
appearance of bundle junctions affects all your harnesses. Harnesses 
created in previous versions may be updated using the Align Bundle 
command on the Location menu. 

Menu Location 
Location > Bundle Alignment 

Improved Subconnector Functionality 

Benefits 
Managing subconnectors in a top-level assembly eliminates the need to 
create assembly coordinate systems as ports to which you route your 
wires. You can use the entry ports stored in the parts. 

With the improved Subconnector functionality, you can create complex, 
top-level assemblies with their own parameters. You can also assign 
parameters to the individual parts that make up the assemblies. The 
BOM will accurately reflect the top-level assembly instead of each 
individual part; which is perfect for prefabricated assemblies. When a 
harnesses is flattened, the top-level assembly is automatically 
assembled to the shortest attached wire segment. You can also show 
the parts individually attached. 

Menu Location 
Logical Reference 
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Modify Network Tangency 

Benefits 
The ability to control network tangency at network branches makes 
auto-routing wires easier and faster. This option reduces the amount of 
time it takes to create a functional network. 

You can control the tangency of a network branch from the user 
interface with no workarounds required. 

Menu Location 
Network Ops > Tangency Operations 

Using the Copy Network Functionality 

Benefits 
The Copy Network functionality significantly reduces the amount of 
work required for routing through cable trays or sections of geometry 
where the harness route needs to be spread out. 

You can copy sections of the network at specified intervals using Copy 
Network. The offset can be modified after creation as necessary. 

Menu Location 
Network Ops > Route > Offset 

Allow References to ECAD Cosmetic Sketches 

Benefits 

Using the ECAD cosmetic area edges as a reference, you can sketch a 
new ECAD area next to an existing ECAD area. 

As you create the ECAD areas on a board part, you can reference the 
edge of another area as needed.  

Menu Location 
Sketcher 

Missing Component Configuration Option  

Benefits 

The ability to set the default placement option for missing components 
to "keep missing" or "delete missing" reduces the amount of time it 
takes to confirm changes to board components. 
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To investigate missing components, add the configuration option 
ECAD_MISSING_COMPONENT_STATUS to your config.pro file. Set the 
values as "keep missing" or "delete missing." After the new option is 
activated, missing components will have the status you have preset in 
the config.pro file. 

Menu Location 

config.pro file 
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7  
Manufacturing 

Manufacturing applications for Pro/ENGINEER Wildfire Help include 
Pro/NC, Expert Machinist, Pro/PROCESS for MFG, Pro/CMM, G-Post, 
and FIL. Highlights of new functionality for this release follow. 

Automatic Mill Window from Silhouette of Reference Part 

Benefits 
Creating a mill window by silhouette minimizes the number of steps 
required to define the window curve. It also minimizes references, 
improves regeneration time, and facilitates automation. 

A mill window is one of the most efficient ways to define an area to be 
machined in Pro/NC. Sketching the references for the window can be 
time-consuming and may create many references. Pro/ENGINEER 
Wildfire speeds up the process by enabling the user to create a mill 
window based on the silhouette of a part (user selected, but from 
reference model by default) viewed along the z-axis of the mill window 
coordinate system. 

You have the option to keep or remove inside loops created by through 
cuts (or holes). 

All Boundary rules (ON, TO, PAST, and Offset) apply to windows 
created by silhouette.  

Menu Location 

Mfg Setup > Mfg Geometry > Mill Window > Create Window 
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Using NC Job Manager for Remote Tool Path Processing 

Benefits 
You can increase productivity by not having to wait for the tool path 
computation to complete. You can also take advantage of powerful 
servers and processing time at night. 

As quality finishing standards increase, so does the time it takes to 
generate the tool paths for cutting materials. The Pro/ENGINEER NC 
Job Manager allows you to select the time and the workstation to be 
used for tool path processing. Computation of tool path sequences does 
not prevent continued use of Pro/ENGINEER by blocking processing. 
You can optionally perform computations out-of-process, so that work 
on subsequent tool path sequences or parts can continue uninterrupted, 
either remotely or on the local machine. 

Menu Location 
Submit Path (during NC Sequence creation) 

Transparent Workpiece Display in Manufacturing Mode 

Benefits 
It is now easier to see the details of the components to be machined 

For assembly machining, the new Pro/ENGINEER Wildfire graphics 
library allows you to display, by default, your workpiece in transparent 
mode. The transparency is controlled by the config.pro option 
mfg_workpiece_transparency, with a default value of .5 for 50% 
transparency. 

Transparent mode applies only to models created in Pro/ENGINEER 
Wildfire. 

Menu Location 

N/A 

Manufacturing File Preview 

Benefits 

You can select the models that you want to work with by previewing 
them before you open Pro/ENGINEER.  

In Pro/ENGINEER Wildfire, you can preview your manufacturing 
models using File > Open > Preview. 
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Manufacturing file preview is also available when you select files in the 
Pro/ENGINEER browser. 

Menu Location 

File > Open > Preview 

Import and Export of Manufacturing Process in XML Format 

Benefits 

Exporting Pro/ENGINEER Wildfire manufacturing processes in XML 
format provides access to all the manufacturing parameters used in a 
specific tool path by using a Web-based standard format. 

Pro/ENGINEER Wildfire exports and imports manufacturing processes 
in XML format. You can use the XML files for multiple tasks, such 
using style sheets to create custom process documentation. 

During the import of the XML files, manufacturing references such as 
coordinate systems, retract planes, and manufacturing geometry are 
automatically assigned, based on feature type and the name stored in 
the XML file. For instance, if the initial tool path was defined using a 
mill window named Outline, and the new manufacturing model 
includes a mill window with the same name, you won't be prompted for 
the reference. This process is similar to a Manufacturing User-Defined 
Feature (MUDF) operation, but with automatic assignment of 
references based on name and type. 

Menu Location 

N/A 

Roughing and Re-Roughing Tool Paths 

Benefits 

The combination of techniques from CADDS 5 (slice calculation) and 
Pro/NC increases tool path¿processing performance and reliability in 
mold machining. 

Pro/ENGINEER Wildfire includes a new NC sequence for roughing and 
re-roughing with the following features (1) An internal tessellated 
model to improve processing performance; (2) Complete support for 
native and non-native data (IGES); (3) Inclusion of all Pro/NC high-
speed machining scan typesconstant load, follow hard wall, and so on; 
(4) Inside/outside tolerances to improve performance and machining 
accuracy; (5) Combination of cutting strategies for both open and close 
areas; and (6) Continuous analysis of the model. 
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Another unique feature, extra slice calculation, allows you to calculate 
an intermediate re-roughing process. When the roughing tool completes 
its normal rough-milling routine, it goes back and reduces height and 
width of the steps it left behind. Therefore, the material is optimally 
prepared for the next tool, and the roughing tool has removed as much 
material as possible. 

Menu Location 

Machining > NC Sequence > Roughing or Re-roughing 

Automatic Solid Tool Export to VERICUT for Pro/ENGINEER 
Benefits 

You no longer need to redefine solid tools in VERICUT for 
Pro/ENGINEER to get an accurate Pro/NC simulation. 

Solid tool assemblies used in Pro/ENGINEER Wildfire for the creation 
of tool paths are exported directly to the VERICUT tool database for 
Pro/NC simulation. By default, the complete tool assembly will be 
exported as a single tool component.The component parameter 
VERICUT_TYPE allows you to control individual part components of 
the tool assembly to be exported as a TOOL or HOLDER. 

For turning-tool assembly, the tool outline is exported. For milling-tool 
assembly the revolution envelope of each tool component is 
exportedThe interface between Pro/ENGINEER and VERICUT for 
Pro/ENGINEER has been modified to handle multiple fixtures, blanked 
layers, and simplified reps. 

What you see in the Pro/ENGINEER Wildfire window is what you get 
in the VERICUT for Pro/ENGINEER window. 

Menu Location 

CL Data > NC Check 

Leading Edge Machining in Trajectory 

Benefits 

Machining with the leading edge maximizes the tool¿s efficiency 
because the center of the tool cannot cut. The 
LEADING_EDGE_MACHINING parameter guarantees this cutting 
condition.. 

The LEADING_EDGE_MACHINING parameter provides a means to 
control flat and corner radius cutters so that they always cut with the 
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leading edge of the tool in trajectory milling. This is particularly 
important for areas of high curvature. 

Menu Location 

N/A 

Tool Axis Definition by Location 

Benefits 
Tool axis definition by location provides more flexibility in the 
definition of a tool-axis control point directly on the geometry of the 
reference part. 

Tool axis definition by location for trajectory milling allows the user to 
place a datum axis at a physical location on the part instead of on a cut 
motion. The tool axis is then applied to the cutter path based on its 
proximity to the cutter path. Interpolation is based on proximity of the 
position on the cutter path to one or more datum axes. 

Menu Location 
Trajectory > Customize > Axis Def 

Integration of VERICUT 5.2 in Pro/ENGINEER Wildfire 

Benefits 
The integration of VERICUT for Pro/ENGINEER makes available the 
latest functionality of VERICUT from CGTECH for PTC customers. 

VERICUT for Pro/ENGINEER offers the following features 
(1) Constant gauge allowing you to dynamically detect potential tool 
path gauges; (2) Tool path review enables you to easily replay all or a 
section of a tool path over the cut stock; (3) Curve fitting improves 
finishes on surfaces and reduces machining cycle time; (4) DXF profile 
import in tool manager; (5) Zoom window provides a zoom view in a 
separate window; (6) Threading simulation; (7) Boring bar and facing 
head support; and (8) Improved simulation performance. 

Menu Location 
CL Data > NC Check 



7-6 Pro/ENGINEER Wildfire Preproduction Release Notes  

Optimized Retract and Connection in Trajectory Milling 

Benefits 
This time-saving functionality minimizes or removes unnecessary 
retract motions in multipass trajectories. You have complete control on 
the connection move between slices. 

When creating a trajectory sequence in Pro/NC using multiple slices 
(start height and step depth), the tool retracts, moves back to the start 
location, and plunges to the depth of the next slice. In Pro/ENGINEER 
Wildfire, you can now control the connection motions with the 
CONNECTION_TYPE parameter using the following options: 
RETRACT - Functionality as currently implemented in 
Pro/ENGINEER 2001; Z LAST - Tool moves from the end point to start 
point in the xy-plane and then plunges in the z-plane; Z FIRST - Tool 
moves from the end point to the new slice depth with a plunge in the z-
plane followed by a positioning move in the xy-plane to the start point; 
SIMULTANEOUS - All three axes move simultaneously from the end 
point to the start point of the next slice. 

Menu Location 
Machining > NC Sequence > Trajectory > Parameters 

Selection of Surfaces for Machining 

Benefits 
The new surface selection mechanism simplifies the manipulation of 
external data for direct machining. 

When machining non-solid surface data that may have been imported 
to Pro/ENGINEER from an external source, the machining algorithms 
need to know which side of each surface should be machined.  

For each quilt an arrow is displayed, and you are required to select 
whether it is the displayed side or the flip side that should be 
machined. 

In Pro/ENGINEER Wildfire, you will be prompted to select the surface 
side for a seed surface, and Pro/ENGINEER will automatically align 
the others surfaces based on the initial selection. 

Menu Location 
Any surface selection in an NC Sequence 
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Mill Window User-Definable Offset 

Benefits 
The Offset option for mill windows minimizes references and number of 
steps, simplifies sketching (if used to define the window), improves 
regeneration time, and facilitates automation. 

When you enter a supplemental value for the Offset option, the value is 
applied to the boundary of the mill window. The offset is applied to the 
default window curve, regardless of the tool condition at the boundary 
(ON, TO, PAST). You can set the direction of the curve offset in the 
sketching plane using a flip arrow. After the offset value is set, the tool 
will offset the boundary by the tool side (ON, TO, PAST) condition and 
the specified value. The default value of the offset is zero. 

Menu Location 

Mfg Setup > Mfg Geometry > Mill Window > Create Window 

Pro/NC-GPOST in Pro/ENGINEER Wildfire 

Benefits 
The integration of Pro/NC-GPOST into Pro/ENGINEER Wildfire 
simplifies post-processor development and reduces the need of FIL 
macro development. The top ten FIL macros have been integrated in 
the Pro/NC-GPOST questionnaire (Optfile). The latest version of 
GPOST from Intercim Austin NC has been integrated into 
Pro/ENGINEER Wildfire. 

Pro/NC-GPOST brings direct support for five-axis milling kinematics, 
including complete "Nutator axis" support, new NURBS interpolation 
support for Bezier format (MAHO), extended registers definition, 
integrated calculator, HTML-based documentation, user-definable tape 
file extension, support for G99/G98, improved Open dialog box, and 
improved FIL macro functions. Many of these enhancements are based 
on the top ten FIL macro requests received by PTC Technical Support.  

The Pro/NC-GPOST page on the PTC Technical Support Web site 
includes a large database of post-processors for download and tutorials 
for Pro/NC-GPOST. 

Menu Location 
Applications > NC Post > processors 
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Model Analysis 

Model analysis applications for Pro/ENGINEER Wildfire Help include 
Behavioral Modeling Extension (BMX), Pro/ENGINEER ModelCHECK 
Extension, and Pro/PROGRAM. Highlights of new functionality for this 
release follow. 

Behavioral Modeling Extension (BMX) 

Behavioral Modeling and Pro/MECHANICA Integration 

Benefits 
The integration of analysis types enables Behavioral Modeling to 
improve designs based on a broader range of problems and addresses 
multidisciplinary problems. 

After you set up an analysis in Pro/MECHANICA, you can turn the 
analysis into an Analysis feature. During the definition of the Analysis 
feature, you can tag the list of quantified results from the Mechanica 
analysis as a computed parameter. Use these computed parameters for 
relations and improvement activities such as Global Optimization and 
Multi-Objective Design Studies.  

Menu Location 
Analysis > Mechanica Analysis 

Using the Graphing Tool 
Benefits 

You have one tool for all graphing in Pro/ENGINEER. Exact formatting 
control allows you to customize the graphs for your needs. 
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The new graphing tool provides consistent formatting control for 
results from Pro/MECHANICA, Mechanism, and Behavioral Modeling. 
Consistent formatting includes representations of the data, background 
colors, axis labels, tick marks, colors and many more capabilities. 

Menu Location 
N/A 

New Global Optimization 

Benefits 
The common issue with gradient-based optimizations of settling into a 
local minimum or maximum goes away. Global Optimization has a 
higher chance of finding the global minimum or maximum. 

To set a Global Optimization, you first define the number of 
experiments to populate the design space. After the number of 
experiments has been filled, Behavioral Modeling uses a Paretto 
capability to identify the best candidates of the populated space. These 
best candidates are then the starting points of the gradient-based 
optimization.  

Menu Location 
Analysis > Feasibility/Optimization > Options > Preferences 

Integration of Behavioral Modeling and Mechanism Analysis 

Benefits 
The integration of analysis types enables Behavioral Modeling to 
improve designs based on a broader range of problems and also 
addresses multidisciplinary problems.  

You can use Pro/ENGINEER parameters to define Mechanism entities. 
The results of mechanism analyses can be used in improvement 
activities, such as optimizations and multi-objective design studies.  

Menu Location 
Analysis > Motion Analysis 
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Pro/ENGINEER ModelCHECK Extension 

ModelCHECK - Check for Circular References 

Benefits 

Circular References should generally be removed from assemblies. 

Circular references are created when one feature (A) references a given 
feature (B) and B in turn references A. When this happens, 
Pro/ENGINEER does not know how to treat each feature and the 
results are unpredictable.  

Menu Location 

CIRCULAR_REFS 

ModelCHECK - Duplicate Model Information Storage in Pro/INTRALINK 

Benefits 

It is now easier to administer Shape Indexing and to find duplicate 
models. 

Menu Location  

N/A 

ModelCHECK - Check for Items Outside the Drawing View Boundary 

Benefits 

With this check, you can detect drawings that have items outside of the 
boundaries of the drawing. 

Menu Location 

This is an enhancement to the existing check BOUND_INFO. 

Improved ModelCHECK User Interface 

Benefits 

Reports are now easier to read and provide more information. You can 
highlight and fix more things from the report. 

The ModelCHECK report appears in the Pro/ENGINEER Web browser. 
The full, interactive report appears immediately. All reports, including 
printable and batch reports, have a consistent look and feel. You can 
filter what types of checks are displayed by selecting check boxes for E 
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(errors), W (warnings), I (info), and checks that passed. The 
config_init.mc options NETSCAPE and BROWSER have been replaced 
with USE_EMBEDDED_BROWSER. The acceptable values for this option 
are Y (yes) and N (no). Setting the option to Y will use the Pro/E 
embedded browser for displaying the report. Setting the option to N will 
use the default browser designated during PTCSetup for displaying the 
report. 

Users can filter what types of checks are displayed by selecting check 
boxes for E (errors), W (warnings), I (info) and checks that passed. 

Menu Location 

FAMILY_INFO configuration option 

ModelCHECK - Check If the Family Table Has Been Verified 
Benefits 

It is important that models with family tables are verified before the 
model is released to a Product Data Management system. 

The report displays the status for nested family tables in addition to 
unregenerated instances or failed regenerations. 

Menu Location 
FAMILY_INFO configuration option 

ModelCHECK - Check for External Dependencies 

Benefits 

Models with external dependencies may behave unexpectedly if they 
are used in multiple assemblies 

Menu Location 

DEPENDENT_FEATURE 
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Mold Design and Casting 

The Pro/ENGINEER Tool Design Option for Pro/ENGINEER Wildfire 
Help includes the following applications: Pro/MOLDESIGN and 
Pro/CASTING. Highlights of new functionality for this release follow. 

Automated Mold/Casting Accuracy Setting 

Benefits 

You no longer must set the absolute accuracy of the Mold/Cast cavity 
model. Time is saved and splitting failures are reduced later in the 
core/cavity creation due to inaccurate geometry. 

After placing the reference part, you are prompted if the reference part 
and the mold/cast cavity (.mfg) accuracies do not match. You can choose 
whether or not you want to change the mold accuracy. 

Menu Location 
N/A 

Automated Undercut Check and Insert Geometry Creation 

Benefits 
When undercut areas in the mold are identified, slider geometry is 
automatically created. This ensures that no undercuts exist and die 
lock conditions are avoided. 

Based on the pull direction indicated for the mold, undercuts are 
detected and identified. The geometry that is necessary to eliminate the 
undercut problem is created automatically. This geometry can be easily 
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modified, extended, and trimmed to create appropriate insert geometry, 
such as a sliding insert. 

Menu Location 

N/A 

New Tangent Draft User Interface 

Benefits 

The streamlined user interface for Tangent Draft simplifies the 
creation of draft geometry for cast and molded parts. 

Graphics in the user interface make selecting and creating the correct 
type of tangent draft more intuitive. 

Menu Location 
N/A 

New Type Tangent Draft Feature 

Benefits 
The process for creating draft for cast and molded parts is simplified 
because you can now remove material for draft creation. 

The surface is automatically drafted and a radius is created that is 
tangent to the adjacent surface. 

Menu Location 

N/A 
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Piping 

Spec-driven and non spec-driven piping are optional applications for 
Pro/ENGINEER Wildfire Help. Highlights of new functionality for this 
release follow. 

Pro/ENGINEER ISOGEN Enabled Piping Design 
(Spec-Driven) 

Pipe-Bend Information on ISOGEN Spool Drawings 

Benefits 

With this enhancement you can generate spool drawings 
instantaneously from ISOGEN. These spool drawings will include all of 
the pipe-bend information necessary for production. 

Critical pipe-bend information is automatically reported to the .pcf file 
that Piping Design produces to drive ISOGEN drawing creation. You 
can create drawing formats that access and report this bend 
information. The resultant drawings are instantaneously created with 
the correct bend tables and information. 

Menu Location 

N/A 
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Pro/ENGINEER Piping Design (Non Spec-Driven) 

Assemble Fittings from Either End of a Pipe Segment 

Benefits 

You can define which end of a pipeline segment the fitting references. 
This choice allows more flexibility during fitting insertion so you can 
add the necessary constraints. 

After you insert a fitting into a pipeline segment, you can toggle the 
end of the segment that is referenced. For example, you insert a check 
valve into a pipeline segment. Then you can select to reference the 
insertion of the fitting to the beginning of the pipe segment or the end 
of the pipe segment. You enter the length constraint as necessary. 

Menu Location 

Fitting > Insert 

Pipeline Assembly Insertion 

Benefits 
Productivity increases on pipeline assemblies with many identical 
pipeline runs. You can insert entire pipelines or sections of pipelines 
from stored models or from within the assembly. 

Pipeline assembly insertion allows you to reuse entire pipelines. You 
can select the entire pipeline or a section of a pipeline, specify the start 
and end segments, and redefine the orientation and angle. 

Menu Location 

Route > Insert 

Route Pipelines from the Free Port on Valid Fittings 

Benefits 

Pipeline segments that are routed from the free port of a valid fitting 
are automatically "joined" to the adjacent ports. This ensures proper 
propagation of the pipeline segments. 

Routing a pipeline from the free port of a tee fitting will automatically 
create an intersection of the centerlines. It is as if you had routed a 
branch off of the main pipeline. If the fitting is replaced, the pipe 
segment that was attached to it will propagate to the new size of the 
fitting. If the pipeline segment is modified, such as changing the angle, 
the fitting will update accordingly. 
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Menu Location 

Route > Set Start > Port 

Improved Extend Feature 

Benefits 

The consolidation of the routing tools in piping provides different 
routing operations from one dialog box, reducing the time it takes to 
route pipeline assemblies. 

Routing is easy when you use one dialog box and can select to route by 
coordinate systems or coordinate system axes and can also define 
references. The EZ router and Extend dialog box in Piping Design 
have been combined into a single, user-friendly tool. 

Menu Location 

Route > Extend 

Consolidated Routing Tool 
Benefits 

The Extend dialog box contains all of the routing tools you need in one 
place. This consolidation reduces the number of selections necessary to 
route pipelines and speeds up routing. 

The EZRouter and the extend features have been combined to enable 
you to quickly and easily move from one extend function to another 
without having to exit and enter menus. 

Menu Location 

Route > Extend 

Enhanced Pipe Routing 

Benefits 

You can create pipelines that have a parametric relationship to other 
pipes or planes. 

This functionality allows you to parametrically route pipelines with 
respect to the top, bottom, left, or right of other pipelines. Pipelines can 
be routed adjacent to other pipes or you can specify an offset distance. 
You can also reference planes. 
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Menu Location 

Route > Set Start > Define Pipe Edge 

Working with Schematic-Driven Piping 

Benefits 

You can reuse data from your system schematic to recreate the 3D 
pipeline assembly and reduce the number of errors caused by 
misinterpretation. 

To use the schematic data from Routed Systems Designer, you must set 
your config.pro option piping_schematic_driven to yes and 
create your pipeline using the pipeline information contained in the 
XML file. 

Menu Location 

Pipeline > Create 

Merging Pipelines 
Benefits 

Multiple users can individually model segments of a single pipeline and 
then merge them when they are done. This makes top-down design 
much easier. 

You can create two sections of a pipeline simultaneously and merge 
them into a single pipeline. This type of design makes it easy for 
companies to split 3D pipeline design work and combine the efforts at 
the end. 

Menu Location 

Pipeline > Merge 

Automatically Assigning Nuts and Bolts 

Benefits 
Nuts and bolts are automatically called out in the BOM. 

You can define nuts and bolts as bulk items and automatically assign 
them based on a code specified in the specification database. 

Menu Location 

Specification database 
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User-Defined, Combined Size Codes 

Benefits 

With the combined_size_code parameter, you can define formats to 
accurately represent a company's naming conventions. 

You create a Defined Size Code table in the pipeod folder in the 
specification database that sets the combined_size_code parameter. 
This parameter is based on existing size parameters in the fitting 
specification. You can then use the combined_size_code parameter 
to define the stock number format or material classification code 
system (MCCS) number. 

Menu Location 

Specification database in the pipeod folder 

Specification Break for Portions of Pipelines 
Benefits 

Because you can change a portion of pipeline specification, you can 
create a pipeline assembly from a single specification and easily modify 
selected sections. 

You select the section of the pipeline that needs to be driven by a 
different specification and change the current specification. All of the 
fittings along the selected section will automatically be updated to the 
new specification. 

Menu Location 

Pipeline > Spec Break 
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Rendering 

Pro/PHOTORENDER provides advanced rendering tools in 
Pro/ENGINEER Wildfire. Highlights of new functionality for this 
release follow. 

Advanced Rendering Extension  

Benefits  
Photorendering, a powerful tool, aids in effectively communicating 
design intent and helps companies market products before they are 
manufactured. Companies can gather critical marketing and sales 
information without having to invest money in production.  

PhotoLux images offer the highest degree of photorealism for a model. 
Combine real-world lighting, accurate reflections and shadows, and the 
fastest render times, and you have the leading rendering software in 
the industry. Advanced features include volumetric light scatter, lens 
flare, depth of field, fog, and more. 

Menu Location 
View > Model Setup > Render Control > Modify rendering 
configuration options 

Real-Time Rendering 

Benefits 

While visualizing and manipulating the model, you can have accurate 
wall reflections and shadow casting onto room walls. 
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Real-time rendering provides valuable graphical feedback and 
visualization in a dynamically rendered environment. Room reflections 
and shadows add to the realism of the Real-Time Rendering 
environment. 

Menu Location 

View > Display Settings > Model Display. In the Model Display 
dialog box, click Display tab > Realtime Rendering. 
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Sheetmetal 

Sheetmetal applications for Pro/ENGINEER Wildfire include 
Pro/SHEETMETAL and Pro/NC-SHEETMETAL. Highlights of new 
functionality for this release follow. 

Pro/SHEETMETAL 

Form Feature Placement 

Benefits 

Form feature placement is the easiest and fastest way to place the 
Form features into sheet metal parts. 

Form feature placement has been enhanced and uses the same user 
interface as Assembly mode uses. The result is a clear and easy way to 
place the Form features. 

Menu Location 
N/A 

Inheritance Feature for Sheetmetal Parts 

Benefits 

When building one-way associative parts related to a master model, 
parts using an inherited feature do not modify the original design. 
Original design changes are in the inherited parts.  

The Inheritance feature allows for the multiple handling of materials, 
toolings, and part shapes while you focus on the final model. For 
example, you may tool a sheet metal part with progressive die, 
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however, while you are waiting for the tooling to complete, you may 
create the laser cut or punched parts with different materials. The 
Inheritance feature helps you to focus on the final part. Any 
modification to this final part is reflected in inherited parts. 
Modification to inherited parts is not reflected in the final part. 

Menu Location 

Insert > Shared Data > Inheritance from Other Model 

Hem Feature Creation 

Benefits 
You can create a full or partial hem on an edge with one feature. 
Because you can keep the initial wall height, the number of required 
actions is reduced.  

The functionality in the Hem feature lets you keep or extend the initial 
wall height with the hem size. Because you can define the Hem feature 
on a partial edge, it includes a relief handling at each side of the hem in 
the same way, or for each side, separately. Required user actions are 
decreased, there are fewer features, and graphical feedback is 
instantaneous. 

Menu Location 

Hem feature 

Convert Extensions and Cut Backs 

Benefits 

The availability of drag handles and the consolidation of create extend 
and create cut walls speeds up your work. 

While performing a conversion, you now have more options regarding 
Edge Rip interaction. In addition to the Open and Overlap options, the 
Blind option is now available.Two drag handles are available on the 
part so you can directly drag the wall lengths. Right-click to see the 
most used values, Thickness extension dimensions and 
2*Thickness extension dimensions. 

Menu Location 

Convert feature 
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Datum Splitting 

Benefits 
In 3D displays you see additional, smaller datums. In 2D drawings, you 
eliminate unnecessary rework. 

Through All cuts now generate a different axis at each wall 
intersection. When you create a Flat Pattern, any hole on the part has a 
center axis that you can use. This would be useful, for example, for a 
production drawing. 

Menu Location 

N/A 

Pro/NC-SHEETMETAL 

Parameters Tool                                      

Benefits 
The Parameter tool allows you to manage parameters.  

You can create, edit, and designate parameters from this dialog box. 
You can also get information about read only parameters. Certain 
parameters, such as those created in Pro/INTRALINK or other PDM 
systems, or driven by relations or Pro/PROGRAM, cannot be modified 
from the Parameter dialog box. These parameters will be shown as 
locked, and will provide the source of the locked status. Parameters can 
also have a status of Unlocked (can be modified anywhere) or Restricted 
(can only be modified from the Parameter dialog box). 

Menu Location 

Tools > Relations 
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Surfacing 

For surfacing tasks in Pro/ENGINEER Wildfire, the following 
applications are available in Help: Pro/SURFACE, Style (ISDX) , 
Restyle, Facet Modeling, Pro/SCANTOOLS, and Warp. Highlights of 
new functionality for this release follow. 

Interactive Reverse Engineering Extension 

Benefits 
The transformation of scan data into a facet model is highly automated. 
You can modify and customize the resultant with simple and complex 
geometry that is not dependent on any data. 

Cutting-edge Restyle tools refine point cloud and polygonal data for 
optimum results. These tools reduce noise or the total points to speed 
up processing without sacrificing detail. You can delete or refine 
triangles to eliminate any error and not compromise surface integrity 
or detail. The transformed data captures the design intent and 
maintains critical geometry for use later. On a facet model, you can 
quick-pick simple surfaces or complex surfaces. You can project a 
surface to fit facet data or to fit boundary surfaces of curves that you 
have sketched. Pro/ENGINEER provides a full set of tools to analyze 
the surface for any deviation from the facet model. You can edit surface 
to change such properties as surface type (NURBS/BEZIER), U/V 
parameters, and so forth. You can manipulate the surface in a free-form 
or numerical manner to fine-tune the model. The result is a modifiable 
and customizable surface representation of a product that fits right the 
first time. 

Menu Location 
Select > Insert > Restyle  
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Primitive Shape Recognition for Surfaces 

Benefits 
Primitive shape recognition highly automates the creation of 
Pro/ENGINEER surfaces on facet data for simple geometry such as 
cylinders, cones, flats, revolutions, and extrusions. 

Shape recognition provides you with an extremely efficient way to 
recognize and create primitive geometry from a facet model. Current 
functionality provides for the recognition of cylinders, cones, flats, 
revolutions, and extrusions. Shape recognition allows the engineer or 
designer the unique opportunity to focus more time on complex areas of 
the model. 

Menu Location 

Insert > Restyle  

Parametric Texture Mapping 

Benefits 
With parametric texture mapping, you can achieve a uniform look in 
color and appearance. Previous placement options did not provide this 
result. 

Appearances, or textures, assume a normal placement at various areas 
of the surface to which they are being applied. Thereby, you can place a 
texture in the optimal position on compound or complex curved 
surfaces. 

Menu Location 
View > Color and Appearance 

Triangular Surface Creation 

Benefits 

Without leaving the Style feature, you can create a boundary surface 
when only three bounding curves are available.  

Boundary surfaces containing only three bounding curves can now be 
created within a Style feature. Triangular surfaces may have internal 
curves. Internal curves that are perpendicular to the natural edge must 
pass through the vertex of the surface patch. You can reposition the 
vertex manually via the dashboard. 
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Menu Location 

Styling > Surface 

Curve and Surface Auto-Regeneration 

Benefits 

With auto-regeneration, you can perform unprecedented visualization 
and design iterations. Exploration of design possibilities takes a 
fraction of the time required by conventional methods. 

Curves and surfaces will now automatically regenerate in real time 
during curve modification. Child curves and surfaces also will update in 
real time as their parents are modified. With auto-regeneration, an 
engineer or designer can experiment with literally thousands of design 
possibilities in seconds. 

Menu Location 

Styling > Curve Edit 

Style Super Feature and Internal Datum Plane Creation 
Benefits 

Internal datum creation provides increased workflow while working 
within a Style feature. 

Internal Datum Plane Creation functionality provides additional 
references for curve and surface creation and eliminates the need to 
leave the Style feature to accomplish this task. Internal Style Datum 
Plane creation is consistent with traditional datum planes in 
Pro/ENGINEER. Internal datums are displayed only while in the Style 
feature and are not visible when the feature is completed 

Menu Location 

Styling > Internal Plane 

Selectively Exposed Style Parameters 

Benefits 
The ability to expose style parameters provides flexibility to use the 
information in BMX analysis, Relations, Family Tables, and so forth. 
Increased workflow and productivity result. 

Style parameters can be selectively exposed outside of the Style 
feature. When you edit the Style feature, the selected parameters 
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become visible in a graphics window for modification or for use in other 
functions within Pro/ENGINEER. Parameters are typically valuable in 
the context of Relations or Family Tables. With style parameters 
exposed, you are relieved from having to redefine the style feature 
when a change is necessary.  

Menu Location 
On the Style dashboard, click the check box next to the desired 
parameter. 

Multiple Curve Edits 

Benefits 

The character within a network of curves is preserved, while you 
manipulate multiple curves. In a single operation, you can assign a 
single value for multiple control points. 

You can edit multiple curves by clicking the Edit Curves icon, then 
holding down CTRL, and selecting the desired curve entities. You can 
then select one or more control points and make the necessary 
modifications. 

Menu Location 

Click the Edit Curves icon. Hold down CTRL while selecting the 
desired curve entities. 

Style Feature and Surface Trimming 

Benefits 
You do not have to exit Style to trim a surface and create desired 
geometry. Workflow and the Model Tree are simplified.  

You can trim surfaces within the Style feature in the same manner as 
within the standard Pro/ENGINEER environment. 

Menu Location 

Trim Selected Quilts icon or Styling > Trim 

Global Modeling Feature (Warp) 

Benefits 
The Warp feature provides quick visual, global modeling without your 
having to consider the construction of the model. With Warp you can 
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use imported data such as IGES in family tables, Relations BMX 
Analysis, and so forth. 

The Pro/ENGINEER Warp feature provides for universal, user-defined 
deformations of selected geometry within a 3D marquee. Selected 
geometry includes facets, curves, surfaces (native and imported), and 
solids. Functionality includes the ability to dynamically scale, reorient, 
taper, stretch, bend, and twist geometry. The resultant Warp feature 
behaves as any other Pro/ENGINEER feature, including the ability to 
make quasi-parametric modifications. 

Menu Location 

Insert > Warp 
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Simulation 

Simulation applications in Wildfire Help include Pro/MECHANICA, 
Mechanism Design Extension, and Mechanism Dynamics Option. 
Highlights of new functionality for this release follow. 

Pro/MECHANICA 

Improved Workflow for Defining and Solving Analyses and Studies  

Benefits 

Many of the menus and dialog boxes you use to define and solve 
analyses are now merged into a new, concise, easier-to-use run form. 

Defining and solving analyses and design studies now takes less time 
and fewer menu selections. 

Description 

The workflow for defining analyses and design studies is streamlined in 
Pro/MECHANICA Wildfire, enabling you to define, edit, run, and view 
the progress of analyses and studies using the same, concise dialog box. 
This new dialog box replaces the old analysis and design study finder 
forms, as well as the old run dialog box. This consolidated dialog box 
makes it much simpler to define analyses. Additionally, the run 
summary and log now share a common window, enabling you to quickly 
toggle between .rpt and .stt file views. This shared window is also 
resizable. 

Menu Location 

Analyses and Studies 
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New Simulation Display Dialog Box  

Benefits 
The simulation visibilities and simulation display dialog boxes are now 
merged into a new dialog boxes that is simpler to use and has more 
functionality. 

You will have greater control over model visualization and interact 
more easily with the new simulation display dialog box. 

Description 
The simulation display settings and display dialog boxes have been 
merged into a better-organized, more fully featured simulation display 
user interface. Some of the new capabilities include the ability to 
display simulation-modeling icons during mode rotations and to fully 
configure the display settings in the config.pro file. This new simulation 
display dialog box is also accessible from a toolbar button. 

Menu Location 

View > Simulation Display 

New Shell Properties Definition Dialog 

Benefits 

A new shell-properties user interface streamlines advanced shell 
definition (by laminate layup or by stiffness). 

Improvements to the shell properties user interface make defining 
advanced shells (either by laminate layup or stiffness) easier and 
quicker. 

Description 
The new shell properties form offers functionality improvements like 
output of laminate layups and stiffnesses to a file, as well as 
enhancements like use of the right mouse button for editing the table 
you use to define laminate plies. 

Menu Location 

Model > Idealizations > Shells > Properties – New 
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No More .mda or .mdb Files for Integrated Mode Models 

Benefits 
All Pro/MECHANICA modeling data for integrated models is now 
stored in Pro/ENGINEER part and assembly files. 

You will have fewer files to track, saving time and minimizing data 
management overhead.  

Description 

All integrated mode simulation modeling data is now stored in 
Pro/ENGINEER part and assembly files. This means you no longer 
have to keep track of .mdb and .mda files, making it easier to manage 
model files and reducing the likelihood of losing modeling data. 

Menu Location 

None 

Pro/MECHANICA and Pro/ENGINEER on the Same CD 

Benefits 

Pro/ENGINEER and Pro/MECHANICA are now installed from the 
same CD-ROM. 

Enjoy simpler, quicker installation as well as fewer release 
incompatibilities between Pro/ENGINEER and Pro/MECHANICA. 

Description 

You now install Pro/MECHANICA and Pro/ENGINEER from the same 
CD-ROM. The process improvements inherent in this approach results 
in faster installation and end date code mismatches between the two 
products. 

Menu Location 

None 

Pro/MECHANICA Configuration Options Merged  
into Pro/ENGINEER config.pro 

Benefits 
Pro/MECHANICA configuration options from the config.mech file have 
been merged into the Pro/ENGINEER preferences file. 
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If you use integrated mode, you save time by no longer needing to 
manage separate configuration files for Pro/MECHANICA and 
Pro/ENGINEER.  

Description 

All integrated mode Pro/MECHANICA simulation settings in the 
config.mech file are now merged into the Pro/ENGINEER config.pro 
preferences file. This lets you escape the overhead of separately 
managing your simulation-modeling environment. It also gives you 
access to the Pro/ENGINEER preference editor's improved usability 
and search capabilities.  

Menu Location 

Tools > Options 

New Assembly Modeling Capabilities  

Benefits 

Pro/MECHANICA features new methods of intelligently joining 
midsurface compressed solid parts, making it easier than ever to model 
assemblies that include such parts. 

This new capability significantly reduces the amount of time it takes to 
set up and solve assemblies that contain midsurface compressed solids. 

Description 

Pro/MECHANICA Wildfire offers dramatic improvements in modeling 
assemblies that contain midsurface compressed parts, such as sheet 
metal assemblies. In the past, such assemblies were painstaking to 
model partly because, once compressed, the components were often no 
longer in contact. You then needed to modify part locations (artificially 
interpenetrate parts by half the material thickness), define connections 
such as welds, or modify the shell pair placement. With these assembly-
modeling enhancements, Pro/MECHANICA detects where components 
are in contact. The software automatically ties the displacements and 
rotations of the contacting surfaces or edges together in the compressed 
model. If you do not want particular surfaces joined, you can either 
leave a small gap in the assembly or define a “Free” connection (also 
new in Pro/MECHANICA Wildfire) between these surfaces. You can 
view the automatically created links in AutoGEM for both integrated 
and independent modes. 

Menu Location 
None 
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Pro/MECHANICA Integration into Behavioral Modeling (BMX) 

Benefits 
Behavioral modeling users can now include Pro/MECHANICA 
measures and analysis in their BMX design studies. 

Pro/MECHANICA integration into BMX gives both BMX and 
Pro/MECHANICA users new, exciting capabilities for optimizing and 
better understanding the behavior of their designs. 

Description 
You can now define analysis features that report measures from a 
specified Pro/MECHANICA analysis. These Pro/MECHANICA analysis 
features can be included in all BMX studies, including feasibility and 
multi-objective design studies. For example, now you can optimize a 
model for center of gravity, stress, and surface area at the same time. 

Menu Location 

Insert > Model Datum > Analysis 

Mass Idealizations Defined from Component 

Benefits 

You can now specify the mass values for mass idealizations directly 
from an assembly component, maintaining the correct value and 
orientation. 

Specifying the mass properties for a mass idealization directly from a 
component minimizes the likelihood of typing errors and incorrect 
orientation. 

Description 

You can now specify the mass of a mass idealization in an assembly by 
selecting a “source” component. This enables you to define the mass 
idealization without having to worry about orientations or the specific 
values of the inertia tensor. "From Component" mass idealizations also 
handle any offset from the application point and the center of gravity 
about which the mass is computed. To define a "From Component" 
mass idealization, you start by creating a simplified representation of 
the assembly that excludes the component to be idealized. Next, you 
move to Pro/MECHANICA and define a mass idealization in the model, 
then select the “source” component for the mass values from the model 
tree. This mass value is associative and updates whenever the source 
component is regenerated. 
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Menu Location 

In an assembly, select Structure > Model > Idealizations > 
Masses > New (Type "Component") 

Import of Convection Coefficients and Bulk Temperatures 

Benefits 

You can now import bulk temperatures and convection coefficients and 
apply them to thermal analysis models. 

You can create more complex analyses involving heterogeneous 
analysis programs such as computational fluid dynamics (CFD). 

Description 

If you use Thermal, you can now import boundary conditions from 
computational fluid dynamics (CFD) software packages. 
Pro/MECHANICA imports the file in a manner similar to that used for 
external temperature loads in the Structure module. The import file 
uses FNF (finite neutral format). This functionality enables you to 
define more complex, multi-physics analyses in Pro/MECHANICA. 

Menu Location 

Thermal > Model > Bndry Conds > New > Conv Cond > Surface 
(Variation set to external) 

Full AutoGEM in Integrated Mode  

Benefits 

Integrated mode users can now use the full interactive AutoGEM 
meshing capabilities featured in independent mode. 

If you encounter meshing problems, you no longer have to go to 
independent mode to diagnose your model. 

Description 
One of the most significant projects introduced in Pro/MECHANICA 
Wildfire is full access to AutoGEM in integrated mode. You can now 
modify mesh settings and interactively create a Pro/MECHANICA 
mesh by selecting volumes or surfaces, or by simply telling AutoGEM to 
mesh all model geometry that has properties (shell, material, and 
beam). As AutoGEM meshes, it displays full information and warnings 
for you to review. Reviewing capabilities include element validation, 
boundary face highlighting, and edge highlighting. Once you are 
satisfied with your mesh, you can save it for use in an analysis. 
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Creating and reviewing the mesh before your run is an optional step; 
you can still run your model without first creating a mesh. 

Menu Location 

Structure > Model – AutoGEM 

Volumetric Heat Loads 

Benefits 

You can now define volumetric heat loads in integrated mode for use in 
thermal analyses. 

Defining volumetric heat loads in integrated mode saves you the effort 
of transferring to independent mode for this functionality. 

Description 

You can now define volumetric heat loads in integrated mode. These 
can be applied to components in an assembly. 

Menu Location 

Thermal > Model > Heat Loads > New > Component 

2D Pressure Loads 

Benefits 

You can now define pressure loads for 2D models such as axisymmetric 
2D models or plane stress 2D models. 

Defining 2D pressure loads in integrated mode saves you the effort of 
transferring to independent mode for this functionality. 

Description 
You can now define pressure loads on curves for 2D models. Unlike 
independent mode where you apply pressure loads to element edges 
instead of curves, you can use the new integrated mode approach more 
robustly in sensitivity and optimization studies. 

Menu Location 

Structure > (select 2D model type) > Loads > New > Pressure 
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P-level Plots 

Benefits 
Integrated mode users can now define P-level results plots. 

Reviewing P-level plots in integrated mode saves you the effort of 
transferring to independent mode for this functionality. 

Description 
P-level plots can now be defined and viewed in integrated mode results. 
Prior to Pro/MECHANICA Wildfire, this capability was only accessible 
in independent mode. 

Menu Location 

Results > Insert > Result Window 
(Fringe > Quantity to be P-level) 

AutoGEM Meshing Performance and Business Improvements  

Benefits 

Pro/MECHANICA Wildfire heralds significant improvements in 
AutoGEM performance and robustness. 

AutoGEM improvements pay dividends by lowering run times for every 
analysis and design study. 

Description 
Pro/MECHANICA Wildfire brings you substantial improvements in 
AutoGEM performance and robustness. You will experience mesh time 
reductions of two to four times, with even greater gains for large models 
and thin solid models. 

Menu Location 
None 

Pro/MECHANICA Solver Performance Improvements  

Benefits 
Pro/MECHANICA solver speed and memory usage have undergone 
dramatic improvements. 

The solver improvements pay dividends by lowering run times for every 
analysis and design study. 
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Description 

Pro/MECHANICA solution performance has been improved by up to 
three times, and memory usage sees reductions of up to 40%. 

Menu Location 

None 

New FEM Tetrahedral Mesher  

Benefits 

A new tetrahedral mesher has been implemented for single volume 
parts. 

The new tetrahedral mesher is much faster, produces higher quality 
elements, and is more robust than the one it replaces.  

Description 
In addition to AutoGEM improvements, Pro/MECHANICA Wildfire 
features an entirely new tetrahedral mesher for FEM mode. At this 
time, the new mesher is available for single volume parts. You will see 
performance improvements of up to an order of magnitude, along with 
much better element quality. Setting the Pro/ENGINEER configuration 
option FEM_NEW_TETRA_MESHER to “yes” activates this option.  

Menu Location 
None 

Redesigned Pro/MECHANICA Results Workflow 

Benefits 
The user interface for defining Pro/MECHANICA results has been 
completely redesigned for improved usability and functionality. 

The new user interface and workflow for defining results windows 
saves you time by making this task much more straightforward and 
gives you many new capabilities. 

Description 

Pro/MECHANICA Wildfire offers tremendous usability and capability 
enhancements in results. You will experience improvements ranging 
from streamlined result window definition to MPEG export for results 
animations. The number of dialog boxes you use to define and display a 
result window has been reduced from four (or more!) to one. In addition 
to a simpler definition user interface, you will notice many other 
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enhancements, including the ability to animate all result types, overlay 
undeformed wireframe or shaded representations of a model on a 
deformed results plot, and add up to 15 color levels to the legend. This 
summary highlights only a few of the enhancements in this area. 

Menu Location 

Results > Insert > Result Window 

Enhancements to Cutting and Capping Planes 

Benefits 

The Pro/MECHANICA results user interface provides improved cutting 
and capping plane definition and functionality. 

The cutting and capping plane enhancements save you time by 
reducing the amount of menu interaction and make it easier to probe 
your results by adding new capabilities.  

Description 

Pro/MECHANICA Wildfire enhancements have made cutting and 
capping plane functionality easier to use and more precise. In addition 
experiencing the benefits of a new, simplified user interface, you can 
now define cutting and capping plane location by specifying a results 
value (either a percentage or a specific number). This provides a quick 
means of isolating areas of high or low stress or displacement for 
further investigation. 

Menu Location 

Results > Insert > Capping > Cutting Surf 

Named Views in Results  

Benefits 

You can now access named views from your Pro/ENGINEER model in 
results. Additionally, you can define and save new views. 

Reusing named views from your Pro/ENGINEER model makes it 
quicker and easier for you to display results exactly the way you want. 

Description 
You can now access views from Pro/ENGINEER in Pro/MECHANICA 
results. Additionally, you can define new views (orientation and zoom 
state) and save these to the results file. 



Simulation 14-11 

Menu Location 

Results > View > Saved View 

Viewed Results by Selecting Components or Layers 

Benefits 

You can now define results in Pro/MECHANICA by selecting which 
Pro/ENGINEER components or layers to display. 

By defining results using Pro/ENGINEER components or layers, you 
save time because you can reuse these definitions from within the 
standard modeling mode.  

Description 

This feature enables you to select the location for which to display 
results by selecting either components or layers from a display tree. 
During layer selection, Pro/MECHANICA only displays layers 
containing simulation model idealizations such as shells or beams. You 
have all the same tools you would for Pro/ENGINEER layers. These 
include hide, show, and isolate.  

Menu Location 

Results > Insert > Result Window (fringe or vector) > Display 
Location (select Component > Layer) 

Annotations in Results  

Benefits 

Pro/MECHANICA now offers results markup capability. You can type 
notes, add leader lines, and draw shapes directly in the results window. 

Sharing and documenting concerns directly in result windows improves 
communication and eliminates the overhead of going to a separate 
package for this functionality. 

Description 

You can now annotate and mark up results windows from within the 
results user interface. You simply type in a note, select its location in 
the result window, and specify whether you want to add a leader line 
pointing to a location in the window. If you select a model location for 
the leader line, Pro/MECHANICA updates the “attachment point" as 
you rotate the model. You can format your annotations by defining text 
style, color, leader style, and so forth. You can also save your 
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annotations. Pro/MECHANICA supports annotations in printed 
reports, exported images, and HTML reports. 

Menu Location 

Results > Insert – Annotation 

Graphing over Multiple Curves or Edges  

Benefits 

You can now use multiple continuously connected curves and beams to 
define the location for graph results. 

You will find it much simpler and quicker to define graphs of results 
quantities where the location traverses multiple curves or beams. 

Description 

You can now select curve and beam chains when defining a graph in 
Pro/MECHANICA results. You can also toggle the start point (left side) 
of the graph. 

Menu Location 

Results > Insert > Result Window (graph) > Display Location 

Principle Stress Vector Results for Solid Models  

Benefits 
You can now define principle stress vector results for solid models in 
Pro/MECHANICA. 

Principle stress vector results for solid model provide you with a better 
understanding of how the model responds to applied loads or 
constraints. 

Description 
You can now define principle stress vector results for models containing 
solid elements. In prior Pro/MECHANICA releases, you could only 
define this type of result for shell models. 

Menu Location 

Results > Insert > Result Window (vector - quantity to be principle 
stress) 
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Multiple Entity Selection for Results Location 

Benefits 
Enhanced display location selection in results enables you to select 
multiple surfaces, curves, or volumes.  

You can now more easily select the display location for 
Pro/MECHANICA results. 

Description 

You can now select multiple volumes, surfaces, or edges for the display 
location in results. In prior Pro/MECHANICA releases, you could only 
select single volumes, surfaces, or edges. 

Menu Location 

Results > Insert > Result Window (fringe or vector) > Display 
Location 

New Graphing Tool 

Benefits 
A new, greatly enhanced graphing tool has been implemented. This tool 
is common to Pro/MECHANICA, Behavioral Modeling, and 
Mechanisms Design. 

The new graphing tool offers significant usability improvements, saving 
you time. Its enhanced capabilities also reduce the need to pass data to 
external graphing programs. 

Description 

Not only does Pro/MECHANICA feature a greatly enhanced results 
user interface, but it provides an entirely new graphing implementation 
too. Pro/MECHANICA, Mechanisms Design, and Behavioral Modeling 
all share this new graphing tool. The graphing tool provides such 
improvements as increased formatting, editing, and display 
capabilities. You will also appreciate the ability to output graphs and 
data directly to MS Excel worksheets. 

Menu Location 

Results > Insert > Result Window (graph) 
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Hierarchical FEM Modeling 

Benefits 
Hierarchical FEM modeling lets you store FEM meshes for component 
models and elevate these meshes to higher-level assemblies, 
incorporating them into the overall system model. 

Your design team saves time because individual contributors can work 
concurrently on the definition of system level analysis models. Plus, you 
experience greater reuse of FEM modeling data. 

Description 

Hierarchical FEM modeling gives analysts the tools to model complex 
assemblies in much the same way that designers model them in 
Pro/ENGINEER. It does this by letting you associate a mesh with a 
specific component, and allowing this mesh to be used in a higher-level 
assembly containing the component. Before you mesh assembly 
components, you define interfaces between these components and copy 
these interfaces into each of the models sharing a particular interface. 
Thus, you can partition large models so multiple teams can work 
concurrently, bringing the system level model together wherever the 
assembly is opened. Another benefit is the ability to reuse previously 
defined component meshes in future assemblies. With hierarchical 
FEM modeling, the mesh persists during modeling so you can see the 
mesh when adding loads, constraints, and materials. You can enable 
this option for models you plan to output to NASTRAN. You do so by 
setting the FEM_MESH_PRESERVE config.pro option to “yes”. 

Menu Location 
None 

Enhanced NASTRAN Modeling Entity Support  

Benefits 
You can now define rigid and weighted links in FEM mode for use in 
NASTRAN. 

Enhanced NASTRAN modeling entity support allows NASTRAN users 
to create more complex structural analysis models. 

Description 

NASTRAN users of FEM mode will see additional support for more 
advanced NASTRAN modeling entities. You can now define rigid and 
weighted links in FEM mode. These modeling entities output RBAR 
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and RBE3 cards to the NASTRAN deck. You can also control the 
degrees of freedom specified in their definition. 

Menu Location 

Model > Connections > Rigid or Weighted Links 

Distributed Masses in FEM Mode 

Benefits 

You can now define masses in FEM mode that are distributed over 
surfaces or curves. 

This new functionality lets you model nonstructural mass (such as 
paint or a wiring harness) in a structural analysis assembly. 

Description 

FEM mode users can now define distributed masses. You apply the 
mass to curves or surfaces and specify the value as either a total value 
or a flux (applied per unit length or per unit area). You can also derive 
the total value from a component mass. 

Menu Location 

Model > Idealizations > Masses > New (select curve or surface 
reference) 

Merged Mechanica Mode and FEM Mode Results 

Benefits 
FEM mode results have been merged into the new Pro/MECHANICA 
post-processor. 

As a result of merging the workflow and capabilities of FEM mode and 
Mechanica mode results, FEM mode users will see enhanced 
functionality and usability. 

Description 
FEM mode results have been merged into the Pro/MECHANICA 
results user interface. In addition to improved usability, FEM mode 
users will be able to access Pro/MECHANICA capabilities such as 
dynamic query, annotations in results, cutting and capping planes, and 
much more. New results quantities include beam stresses and strains.  

Menu Location 

Results. Ansys results are unchanged. 
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Mechanism Design Extension (MDX) 

Mechanism > Component Motion Envelope 
Benefits 

By efficiently isolating the capture of swept volumes of interest to 
selected components, you improve envelope quality and reduce creation 
time. 

After running an analysis, you can directly create motion envelopes 
from the Playback dialog box. Select the desired components and 
quality level. Then preview the envelope or save it as a part. 

Menu Location 

Applications > Mechanism > Mechanism > Playback 

Mechanism > Parametric Motor Profiles 

Benefits 
You can specify motor profile definitions that respond to change. By 
leveraging BMX design studies, you can optimize mechanism 
performance over a range of input characteristics. 

Create and assign values for numeric Pro/ENGINEER assembly 
parameters. When creating a Servo Motor, select the user-defined 
magnitude type and define an expression. Activate the desired 
parameters and specify the mathematical expression for the magnitude 
profile. 

Menu Location 

Applications, Mechanism, Mechanism, Servo Motors 

Mechanism > Graph Tracking Bar 

Benefits 

You can pinpoint key performance events, such as acceleration spikes 
and dwell periods, by simultaneously tracking a graphed measurement 
while observing the mechanism in motion. 

For a particular analysis, you can graph desired measures of interest. 
With the graph window displayed, you can animate the mechanism by 
starting the analysis playback. A vertical tracking bar in each graph 
window changes position as the playback progresses. 
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Menu Location 

Applications > Mechanism > Mechanism > Measures 

Mechanism > Servo Motor Velocity & Acceleration Graphs 

Benefits 

Before running an analysis, you can review, examine, and compare the 
position velocity or acceleration characteristics of a Servo Motor profile. 

Mechanism Design Extension performs the necessary integration and 
derivative calculations to compute and graph position, velocity, and 
acceleration. When defining the profile of a Servo Motor, select one or 
more graphing optionsposition, velocity, or acceleration. You can plot 
the individual profiles on the same graph or in separate graphs that are 
stacked vertically for comparison. 

Menu Location 

Applications > Mechanism > Mechanism > Servo Motors 

Mechanism - True Kinematic Analysis 

Benefits 

You can evaluate the kinematic performance of a mechanism without 
having to assign mass properties to assembly components.  

Pro/ENGINEER Foundation alone represents a comprehensive 
kinematic simulation tool for mechanism design without requiring any 
additional modules. First, create measures for the velocity and 
acceleration of a point or joint. Then create and run a kinematic 
analysis. The velocity and acceleration measure data can be graphed or 
displayed as animated vector arrows during playback of the analysis. 

Menu Location 

Applications > Mechanism > Analysis > Kinematic 

Mechanism - Object Action for Direct Interaction 

Benefits 

Quickly and easily, you can create, review, delete, or edit mechanism 
features such as connection properties, Servo Motors, or gears through 
direct interaction with the assembly model. 

Select a mechanism icon and right-click to reveal a shortcut menu with 
pertinent actions. Select a joint axis to edit its settings or to create a 
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motor. Select a Servo Motor to review its current properties in an 
information window, edit its profile characteristics, or simply delete it. 
Each mechanism feature icon provides access to its own associated 
actions. 

Menu Location 

Applications > Mechanism 

Mechanism - Gear Connections 

Benefits 

Gear connections provide a generalized method of modeling spur, bevel, 
helical, rack and pinion, and worm gear combinations, as well as 
idealized pulley pairs. 

Select two joint axes and either define appropriate pitch circle 
diameters to allow Mechanism Design to assign a gear ratio, or define 
your own ratio to be enforced between the moving bodies. 

Menu Location 

Applications > Mechanism > Mechanism > Gears 

Mechanism - Enhanced Animation Capture 

Benefits 

New capture options ensure the creation of quality animation files in 
an expanded range of file types. 

The aspect ratio of captured animation files can now be locked to the 
aspect ratio of the displayed model, helping to ensure quality images 
free of distortion. A new setting allows adjustment of frame rate for 
MPEG animations. Export options now include the TIFF and Windows 
BMP file types. 

Menu Location 

Applications > Mechanism > Mechanism > Playback > Capture 
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Mechanism Dynamics Option (MDO) 

Mechanism - Measure Dependent Forces 

Benefits 

To a mechanism you can apply forces of angular orientation, separation 
distance, velocity, and so forth, which cannot be described easily as 
functions of time. 

Create appropriate position or velocity measures. When creating a 
Force Motor, a Point Force, or a Body Torque, select the user-defined 
magnitude type. Then select the desired measure from the variable list, 
and specify a mathematical expression and domain for the magnitude 
profile. 

Menu Location 

Applications > Mechanism > Mechanism > Force Motors 

Mechanism - Static Analysis Progress Graph 

Benefits 

Observe and track the solution progress of a static analysis by 
monitoring the updated graph of maximum system acceleration as it 
approaches zero. 

When running a static analysis using the Mechanism Dynamics Option 
(MDO), the mechanism animates, and a graph of maximum system 
acceleration appears. The graph updates with each solution step.  

Menu Location 

Applications > Mechanism > Analysis > Static 
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15 
Distributed Applications 

Distributed applications for Pro/ENGINEER Wildfire Help include 
Distributed Pro/BATCH and Distributed Services Manager (DSM). 
Highlights of new functionality for this release follow. 

Distributed Pro/BATCH 

Data Exchange 

Benefits 
With Pro/BATCH, you can offload tasks to remote servers to boost 
productivity and broaden organizational access to Pro/ENGINEER. 

Distributed Pro/BATCH performs batch jobs in a distributed 
environment by leveraging hardware and software resources on your 
network. Using Distributed Pro/BATCH, you can perform large 
volumes of routine, time-consuming, and computer-intensive tasks, 
such as plotting, importing and exporting of 2D and 3D data, and batch 
execution of ModelCHECK. By using Distributed Services Manager, a 
distributed resource and services management software system, jobs 
are queued if resources are unavailable. In addition, system 
administrators can schedule the processing of batch type jobs over the 
network at low traffic times. A Web interface provides clients with the 
current status of pending jobs from any location. Distributed 
Pro/BATCH and the Distributed Services Manager are built from the 
Web up by incorporating open standards and Web protocols, such as 
SOAP, XML, and HTTP. 

Menu Location 
N/A 
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Distributed Services Manager (DSM) 

Data Exchange 

Benefits 
With DSM, you can schedule the processing of distributed tasks and 
queue the tasks when resources are unavailable. A centralized hub 
connects all distributed clients and services on the network. 

Distributed Services Manager (DSM) is new for release with 
Pro/ENGINEER Wildfire. With DSM, engineers or CAD Administrators 
can set up and manage a server farm of network resources. Remote 
clients can request tasks from the DSM, which assigns these tasks to 
available service resources or queues the tasks if necessary. The service 
resources host one or more server-side applications, such as Distributed 
Pro/BATCH, to perform the requested task. Distributed Pro/BATCH is 
the first distributed service developed by PTC to provide distributed 
resource management. 

Companies can leverage DSM technology in the scheduling the 
availability of services in response to requests from remote clients. A 
Web-portal provides you with online access to monitor the progress of 
jobs from any location. DSM provides the latest Web-based distributed 
computing protocols and open standards, namely SOAP, XML, and 
HTTP. 

Menu Location 

N/A 

 


